summary refs log tree commit diff
path: root/nixos/modules/rename.nix
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2018-06-20 22:21:52 +0100
committerGitHub <noreply@github.com>2018-06-20 22:21:52 +0100
commitd63cb0695f6708f88d15a17e770db5abef8f45fc (patch)
tree0021de339ae41c5fd065340600baaa2d7a626a0f /nixos/modules/rename.nix
parent80fa12f1cfe6944efaa7e32101bec6ba5da9e0de (diff)
parent6dc06fdd282dcfd1ca46160b196dc2c2676aa86d (diff)
downloadnixlib-d63cb0695f6708f88d15a17e770db5abef8f45fc.tar
nixlib-d63cb0695f6708f88d15a17e770db5abef8f45fc.tar.gz
nixlib-d63cb0695f6708f88d15a17e770db5abef8f45fc.tar.bz2
nixlib-d63cb0695f6708f88d15a17e770db5abef8f45fc.tar.lz
nixlib-d63cb0695f6708f88d15a17e770db5abef8f45fc.tar.xz
nixlib-d63cb0695f6708f88d15a17e770db5abef8f45fc.tar.zst
nixlib-d63cb0695f6708f88d15a17e770db5abef8f45fc.zip
Merge pull request #42133 from markuskowa/pgbackup
nixos/pgbackup: Fix and refactor the postgres backup module
Diffstat (limited to 'nixos/modules/rename.nix')
-rw-r--r--nixos/modules/rename.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/nixos/modules/rename.nix b/nixos/modules/rename.nix
index e3691843e170..7b094fc14203 100644
--- a/nixos/modules/rename.nix
+++ b/nixos/modules/rename.nix
@@ -200,6 +200,12 @@ with lib;
     (mkRenamedOptionModule [ "fonts" "fontconfig" "ultimate" "forceAutohint" ] [ "fonts" "fontconfig" "forceAutohint" ])
     (mkRenamedOptionModule [ "fonts" "fontconfig" "ultimate" "renderMonoTTFAsBitmap" ] [ "fonts" "fontconfig" "renderMonoTTFAsBitmap" ])
 
+    # postgresqlBackup
+    (mkRemovedOptionModule [ "services" "postgresqlBackup" "period" ] ''
+       A systemd timer is now used instead of cron.
+       The starting time can be configured via <literal>services.postgresqlBackup.startAt</literal>.
+    '')
+
     # Profile splitting
     (mkRenamedOptionModule [ "virtualization" "growPartition" ] [ "boot" "growPartition" ])