summary refs log tree commit diff
path: root/nixos/modules/rename.nix
diff options
context:
space:
mode:
authorMitchell Pleune <mitchpleune@gmail.com>2016-03-26 12:02:00 -0400
committerMitchell Pleune <mitchpleune@gmail.com>2016-03-26 21:16:29 -0400
commit879778091a5f8280a72a577b536137fa7a7a852a (patch)
tree91409e95941bc694166f72e8048d74d8cabae21b /nixos/modules/rename.nix
parent45a2d9e177737aff5fae21854c5420804a59743b (diff)
downloadnixlib-879778091a5f8280a72a577b536137fa7a7a852a.tar
nixlib-879778091a5f8280a72a577b536137fa7a7a852a.tar.gz
nixlib-879778091a5f8280a72a577b536137fa7a7a852a.tar.bz2
nixlib-879778091a5f8280a72a577b536137fa7a7a852a.tar.lz
nixlib-879778091a5f8280a72a577b536137fa7a7a852a.tar.xz
nixlib-879778091a5f8280a72a577b536137fa7a7a852a.tar.zst
nixlib-879778091a5f8280a72a577b536137fa7a7a852a.zip
iodine service: add clients implimentation
- services.iodined moved to services.iodine
- configuration file backwards compatable
- old iodine server configuration moved to services.iodine.server
- attribute set services.iodine.clients added to specify any number
  of iodine clients
  - example:
    iodine.clients.home = { server = "iodinesubdomain.yourserver.com"; ... };
  - client services names iodine-name where name would be home
Diffstat (limited to 'nixos/modules/rename.nix')
-rw-r--r--nixos/modules/rename.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/nixos/modules/rename.nix b/nixos/modules/rename.nix
index c6a781b6f00f..84eccfd51292 100644
--- a/nixos/modules/rename.nix
+++ b/nixos/modules/rename.nix
@@ -101,6 +101,13 @@ with lib;
     # Enlightenment
     (mkRenamedOptionModule [ "services" "xserver" "desktopManager" "e19" "enable" ] [ "services" "xserver" "desktopManager" "enlightenment" "enable" ])
 
+    # Iodine
+    (mkRenamedOptionModule [ "services" "iodined" "enable" ] [ "services" "iodine" "server" "enable" ])
+    (mkRenamedOptionModule [ "services" "iodined" "domain" ] [ "services" "iodine" "server" "domain" ])
+    (mkRenamedOptionModule [ "services" "iodined" "ip" ] [ "services" "iodine" "server" "ip" ])
+    (mkRenamedOptionModule [ "services" "iodined" "extraConfig" ] [ "services" "iodine" "server" "extraConfig" ])
+    (mkRemovedOptionModule [ "services" "iodined" "client" ])
+
     # Options that are obsolete and have no replacement.
     (mkRemovedOptionModule [ "boot" "initrd" "luks" "enable" ])
     (mkRemovedOptionModule [ "programs" "bash" "enable" ])