summary refs log tree commit diff
path: root/nixos/modules/rename.nix
diff options
context:
space:
mode:
authorFranz Pletz <fpletz@fnordicwalking.de>2018-03-28 02:30:50 +0200
committerFranz Pletz <fpletz@fnordicwalking.de>2018-03-28 02:30:50 +0200
commit70c6f6572dda0f2516bad812857ef814ec710a12 (patch)
tree1ce824a4d17635ed2127927d533b51b1b52a64d8 /nixos/modules/rename.nix
parente6f4614e8582e0ea11995a6756b7f25abbc391cc (diff)
downloadnixlib-70c6f6572dda0f2516bad812857ef814ec710a12.tar
nixlib-70c6f6572dda0f2516bad812857ef814ec710a12.tar.gz
nixlib-70c6f6572dda0f2516bad812857ef814ec710a12.tar.bz2
nixlib-70c6f6572dda0f2516bad812857ef814ec710a12.tar.lz
nixlib-70c6f6572dda0f2516bad812857ef814ec710a12.tar.xz
nixlib-70c6f6572dda0f2516bad812857ef814ec710a12.tar.zst
nixlib-70c6f6572dda0f2516bad812857ef814ec710a12.zip
nixos/version: fix nixops pre 1.6 compatibility
We should be able to deploy a NixOS 18.03 system with the current nixops
stable release. Some options were renamed, so instead of
`mkRenamedOptionModule` we introduce them as read-only interal options
that won't be rendered in the manual.

Only the options that are needed to make nixops evaluations succeed were
added.

This commit should probably be reverted after or before the 18.09 release,
depending on the nixops 1.6 release.

The user will not get the warning that these have been renamed but
this change is mentioned in the release notes.

Fixes #34253.
Diffstat (limited to 'nixos/modules/rename.nix')
-rw-r--r--nixos/modules/rename.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nixos/modules/rename.nix b/nixos/modules/rename.nix
index b0ca274b939f..288634343750 100644
--- a/nixos/modules/rename.nix
+++ b/nixos/modules/rename.nix
@@ -196,9 +196,9 @@ with lib;
     (mkRenamedOptionModule [ "virtualization" "growPartition" ] [ "boot" "growPartition" ])
 
     # misc/version.nix
-    (mkRenamedOptionModule [ "config" "system" "nixosVersion" ] [ "config" "system" "nixos" "version" ])
+    #(mkRenamedOptionModule [ "config" "system" "nixosVersion" ] [ "config" "system" "nixos" "version" ])
     (mkRenamedOptionModule [ "config" "system" "nixosRelease" ] [ "config" "system" "nixos" "release" ])
-    (mkRenamedOptionModule [ "config" "system" "nixosVersionSuffix" ] [ "config" "system" "nixos" "versionSuffix" ])
+    #(mkRenamedOptionModule [ "config" "system" "nixosVersionSuffix" ] [ "config" "system" "nixos" "versionSuffix" ])
     (mkRenamedOptionModule [ "config" "system" "nixosRevision" ] [ "config" "system" "nixos" "revision" ])
     (mkRenamedOptionModule [ "config" "system" "nixosCodeName" ] [ "config" "system" "nixos" "codeName" ])
     (mkRenamedOptionModule [ "config" "system" "nixosLabel" ] [ "config" "system" "nixos" "label" ])