summary refs log tree commit diff
path: root/nixos/modules/programs/zsh/zsh.nix
diff options
context:
space:
mode:
authorYacine Hmito <gpyh@users.noreply.github.com>2017-01-11 07:00:48 +0100
committerFranz Pletz <fpletz@fnordicwalking.de>2017-01-11 07:00:48 +0100
commitf88e2fb5f170591e7e5c6f63470a5a187935a553 (patch)
tree70c30dcc8c3350743ff016efb70f10bfbe558539 /nixos/modules/programs/zsh/zsh.nix
parentc03bc5721203d4952bc7c4b90efedeee4383780c (diff)
downloadnixlib-f88e2fb5f170591e7e5c6f63470a5a187935a553.tar
nixlib-f88e2fb5f170591e7e5c6f63470a5a187935a553.tar.gz
nixlib-f88e2fb5f170591e7e5c6f63470a5a187935a553.tar.bz2
nixlib-f88e2fb5f170591e7e5c6f63470a5a187935a553.tar.lz
nixlib-f88e2fb5f170591e7e5c6f63470a5a187935a553.tar.xz
nixlib-f88e2fb5f170591e7e5c6f63470a5a187935a553.tar.zst
nixlib-f88e2fb5f170591e7e5c6f63470a5a187935a553.zip
zsh-autosuggestions: init at 0.3.3 (#21792)
Added a related `programs.zsh.enableAutosuggestions` option
Diffstat (limited to 'nixos/modules/programs/zsh/zsh.nix')
-rw-r--r--nixos/modules/programs/zsh/zsh.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/nixos/modules/programs/zsh/zsh.nix b/nixos/modules/programs/zsh/zsh.nix
index 5b7d94157454..b4d941a7770c 100644
--- a/nixos/modules/programs/zsh/zsh.nix
+++ b/nixos/modules/programs/zsh/zsh.nix
@@ -91,6 +91,13 @@ in
         '';
         type = types.bool;
       };
+      
+      enableAutosuggestions = mkOption {
+        default = false;
+        description = ''
+          Enable zsh-autosuggestions
+        '';
+      };
 
     };
 
@@ -132,6 +139,10 @@ in
           "source ${pkgs.zsh-syntax-highlighting}/share/zsh-syntax-highlighting/zsh-syntax-highlighting.zsh"
         }
 
+        ${optionalString (cfg.enableAutosuggestions)
+          "source ${pkgs.zsh-autosuggestions}/share/zsh-autosuggestions/zsh-autosuggestions.zsh"
+        }
+
         HELPDIR="${pkgs.zsh}/share/zsh/$ZSH_VERSION/help"
       '';