summary refs log tree commit diff
path: root/nixos/modules/programs/zsh/zsh.nix
diff options
context:
space:
mode:
authorRok Garbas <rok@garbas.si>2016-09-04 16:30:07 +0200
committerRok Garbas <rok@garbas.si>2016-09-04 16:31:29 +0200
commit095c7aefe1c5d7fea8467f19473a1895cb2df17f (patch)
tree7b38d7edb064a6a1f264233a6b95ecf5fc6b5012 /nixos/modules/programs/zsh/zsh.nix
parent5d7adc7b093a00b3dc0ef97fa657160815161b9f (diff)
downloadnixlib-095c7aefe1c5d7fea8467f19473a1895cb2df17f.tar
nixlib-095c7aefe1c5d7fea8467f19473a1895cb2df17f.tar.gz
nixlib-095c7aefe1c5d7fea8467f19473a1895cb2df17f.tar.bz2
nixlib-095c7aefe1c5d7fea8467f19473a1895cb2df17f.tar.lz
nixlib-095c7aefe1c5d7fea8467f19473a1895cb2df17f.tar.xz
nixlib-095c7aefe1c5d7fea8467f19473a1895cb2df17f.tar.zst
nixlib-095c7aefe1c5d7fea8467f19473a1895cb2df17f.zip
nixos/manual: mentioning other zsh options at program.zsh.enable
fixes #13224
Diffstat (limited to 'nixos/modules/programs/zsh/zsh.nix')
-rw-r--r--nixos/modules/programs/zsh/zsh.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/nixos/modules/programs/zsh/zsh.nix b/nixos/modules/programs/zsh/zsh.nix
index 1b8b7a79593e..91cd84416921 100644
--- a/nixos/modules/programs/zsh/zsh.nix
+++ b/nixos/modules/programs/zsh/zsh.nix
@@ -25,7 +25,10 @@ in
       enable = mkOption {
         default = false;
         description = ''
-          Whether to configure zsh as an interactive shell.
+          Whether to configure zsh as an interactive shell. To enable zsh for
+          a particular user, use the <option>users.users.&lt;name?&gt;.shell</option>
+          option for that user. To enable zsh system-wide use the
+          <option>users.defaultUserShell</option> option.
         '';
         type = types.bool;
       };