summary refs log tree commit diff
path: root/nixos/modules/programs/zsh/zsh-syntax-highlighting.nix
diff options
context:
space:
mode:
authorMaximilian Bosch <maximilian@mbosch.me>2017-05-30 14:40:25 +0200
committerMaximilian Bosch <maximilian@mbosch.me>2017-05-31 21:52:05 +0200
commitc4e4071ed115aca6ad8e7a15429638b2c497e790 (patch)
tree9adc7f636b53382c5254ea7571021ca8341595c6 /nixos/modules/programs/zsh/zsh-syntax-highlighting.nix
parent0925f79d561b077c40c53e3fb213df461bdf2b06 (diff)
downloadnixlib-c4e4071ed115aca6ad8e7a15429638b2c497e790.tar
nixlib-c4e4071ed115aca6ad8e7a15429638b2c497e790.tar.gz
nixlib-c4e4071ed115aca6ad8e7a15429638b2c497e790.tar.bz2
nixlib-c4e4071ed115aca6ad8e7a15429638b2c497e790.tar.lz
nixlib-c4e4071ed115aca6ad8e7a15429638b2c497e790.tar.xz
nixlib-c4e4071ed115aca6ad8e7a15429638b2c497e790.tar.zst
nixlib-c4e4071ed115aca6ad8e7a15429638b2c497e790.zip
programs.zsh.syntax-highlighting: simplify enable option by using `mkEnableOption`
Diffstat (limited to 'nixos/modules/programs/zsh/zsh-syntax-highlighting.nix')
-rw-r--r--nixos/modules/programs/zsh/zsh-syntax-highlighting.nix8
1 files changed, 1 insertions, 7 deletions
diff --git a/nixos/modules/programs/zsh/zsh-syntax-highlighting.nix b/nixos/modules/programs/zsh/zsh-syntax-highlighting.nix
index 1dded0387951..3bd7ab818961 100644
--- a/nixos/modules/programs/zsh/zsh-syntax-highlighting.nix
+++ b/nixos/modules/programs/zsh/zsh-syntax-highlighting.nix
@@ -8,13 +8,7 @@ in
   {
     options = {
       programs.zsh.syntaxHighlighting = {
-        enable = mkOption {
-          default = false;
-          type = types.bool;
-          description = ''
-            Enable zsh-syntax-highlighting.
-          '';
-        };
+        enable = mkEnableOption "zsh-syntax-highlighting";
 
         highlighters = mkOption {
           default = [ "main" ];