summary refs log tree commit diff
path: root/nixos/modules/programs/xfs_quota.nix
diff options
context:
space:
mode:
authorJan Malakhovski <oxij@oxij.org>2015-08-17 17:52:45 +0000
committerJan Malakhovski <oxij@oxij.org>2015-09-18 18:48:50 +0000
commit6eadb16022b6e52f3cdb2167aaa7b82e221bfc1a (patch)
tree55e2983e16662e1074e9e668998253d31b429d59 /nixos/modules/programs/xfs_quota.nix
parent33ae3f2fe4baeb4db19d3c90dbb6cd35b9373004 (diff)
downloadnixlib-6eadb16022b6e52f3cdb2167aaa7b82e221bfc1a.tar
nixlib-6eadb16022b6e52f3cdb2167aaa7b82e221bfc1a.tar.gz
nixlib-6eadb16022b6e52f3cdb2167aaa7b82e221bfc1a.tar.bz2
nixlib-6eadb16022b6e52f3cdb2167aaa7b82e221bfc1a.tar.lz
nixlib-6eadb16022b6e52f3cdb2167aaa7b82e221bfc1a.tar.xz
nixlib-6eadb16022b6e52f3cdb2167aaa7b82e221bfc1a.tar.zst
nixlib-6eadb16022b6e52f3cdb2167aaa7b82e221bfc1a.zip
nixos: fix some types
Diffstat (limited to 'nixos/modules/programs/xfs_quota.nix')
-rw-r--r--nixos/modules/programs/xfs_quota.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/nixos/modules/programs/xfs_quota.nix b/nixos/modules/programs/xfs_quota.nix
index d30a85922cff..90b6304fa999 100644
--- a/nixos/modules/programs/xfs_quota.nix
+++ b/nixos/modules/programs/xfs_quota.nix
@@ -32,25 +32,25 @@ in
             };
 
             fileSystem = mkOption {
-              type = types.string;
+              type = types.str;
               description = "XFS filesystem hosting the xfs_quota project.";
               default = "/";
             };
 
             path = mkOption {
-              type = types.string;
+              type = types.str;
               description = "Project directory.";
             };
 
             sizeSoftLimit = mkOption {
-              type = types.nullOr types.string;
+              type = types.nullOr types.str;
               default = null;
               example = "30g";
               description = "Soft limit of the project size";
             };
 
             sizeHardLimit = mkOption {
-              type = types.nullOr types.string;
+              type = types.nullOr types.str;
               default = null;
               example = "50g";
               description = "Hard limit of the project size.";