summary refs log tree commit diff
path: root/nixos/modules/programs/tmux.nix
diff options
context:
space:
mode:
authorFranz Pletz <fpletz@fnordicwalking.de>2017-03-17 23:31:52 +0100
committerFranz Pletz <fpletz@fnordicwalking.de>2017-03-17 23:36:19 +0100
commit953616907493c5b81ba3ec9dd86f1422f4d1fcd3 (patch)
tree1ebe5e1caaed3b8a5920280bba56406974202326 /nixos/modules/programs/tmux.nix
parenta8785daf0ea794f1791c598c6cac9db3858b45bb (diff)
downloadnixlib-953616907493c5b81ba3ec9dd86f1422f4d1fcd3.tar
nixlib-953616907493c5b81ba3ec9dd86f1422f4d1fcd3.tar.gz
nixlib-953616907493c5b81ba3ec9dd86f1422f4d1fcd3.tar.bz2
nixlib-953616907493c5b81ba3ec9dd86f1422f4d1fcd3.tar.lz
nixlib-953616907493c5b81ba3ec9dd86f1422f4d1fcd3.tar.xz
nixlib-953616907493c5b81ba3ec9dd86f1422f4d1fcd3.tar.zst
nixlib-953616907493c5b81ba3ec9dd86f1422f4d1fcd3.zip
nixos/treewide: remove boolean examples for options
They contain no useful information and increase the length of the
autogenerated options documentation.

See discussion in #18816.
Diffstat (limited to 'nixos/modules/programs/tmux.nix')
-rw-r--r--nixos/modules/programs/tmux.nix5
1 files changed, 0 insertions, 5 deletions
diff --git a/nixos/modules/programs/tmux.nix b/nixos/modules/programs/tmux.nix
index f0f8d03505ac..ed1d88a420a2 100644
--- a/nixos/modules/programs/tmux.nix
+++ b/nixos/modules/programs/tmux.nix
@@ -65,7 +65,6 @@ in {
 
       aggressiveResize = mkOption {
         default = false;
-        example = true;
         type = types.bool;
         description = ''
           Resize the window to the size of the smallest session for which it is the current window.
@@ -81,14 +80,12 @@ in {
 
       clock24 = mkOption {
         default = false;
-        example = true;
         type = types.bool;
         description = "Use 24 hour clock.";
       };
 
       customPaneNavigationAndResize = mkOption {
         default = false;
-        example = true;
         type = types.bool;
         description = "Override the hjkl and HJKL bindings for pane navigation and resizing in VI mode.";
       };
@@ -124,14 +121,12 @@ in {
 
       newSession = mkOption {
         default = false;
-        example = true;
         type = types.bool;
         description = "Automatically spawn a session if trying to attach and none are running.";
       };
 
       reverseSplit = mkOption {
         default = false;
-        example = true;
         type = types.bool;
         description = "Reverse the window split shortcuts.";
       };