summary refs log tree commit diff
path: root/nixos/modules/programs/ssh.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2015-09-24 11:42:32 +0200
committerEelco Dolstra <eelco.dolstra@logicblox.com>2015-09-24 11:50:58 +0200
commit89e983786a4e2cf6dd238af4df6da373cc01e62b (patch)
tree857ecb8eab59fe1855b1fb311e6e1e9ec8303bdc /nixos/modules/programs/ssh.nix
parente73b19ae4e984f58cebe4dd4f82cda622da552ab (diff)
downloadnixlib-89e983786a4e2cf6dd238af4df6da373cc01e62b.tar
nixlib-89e983786a4e2cf6dd238af4df6da373cc01e62b.tar.gz
nixlib-89e983786a4e2cf6dd238af4df6da373cc01e62b.tar.bz2
nixlib-89e983786a4e2cf6dd238af4df6da373cc01e62b.tar.lz
nixlib-89e983786a4e2cf6dd238af4df6da373cc01e62b.tar.xz
nixlib-89e983786a4e2cf6dd238af4df6da373cc01e62b.tar.zst
nixlib-89e983786a4e2cf6dd238af4df6da373cc01e62b.zip
Manual: Remove store path references
Diffstat (limited to 'nixos/modules/programs/ssh.nix')
-rw-r--r--nixos/modules/programs/ssh.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/nixos/modules/programs/ssh.nix b/nixos/modules/programs/ssh.nix
index cf7ef455eb85..87a7bac208b7 100644
--- a/nixos/modules/programs/ssh.nix
+++ b/nixos/modules/programs/ssh.nix
@@ -36,7 +36,6 @@ in
 
       askPassword = mkOption {
         type = types.str;
-        default = "${pkgs.x11_ssh_askpass}/libexec/x11-ssh-askpass";
         description = ''Program used by SSH to ask for passwords.'';
       };
 
@@ -223,5 +222,7 @@ in
         export SSH_ASKPASS=${askPassword}
       '';
 
+    programs.ssh.askPassword = mkDefault "${pkgs.x11_ssh_askpass}/libexec/x11-ssh-askpass";
+
   };
 }