summary refs log tree commit diff
path: root/nixos/modules/programs/rootston.nix
diff options
context:
space:
mode:
authorgnidorah <gnidorah@users.noreply.github.com>2017-12-26 22:57:00 +0300
committergnidorah <gnidorah@users.noreply.github.com>2017-12-26 23:31:38 +0300
commitececaafee17dcdef24fae812e0a2721ed392e968 (patch)
treec8913f449e7b8d1f79ad90f2935b27c3ddb83db5 /nixos/modules/programs/rootston.nix
parent4271a210b0ac9fbbea5382ddee1cfa835f3e35b9 (diff)
downloadnixlib-ececaafee17dcdef24fae812e0a2721ed392e968.tar
nixlib-ececaafee17dcdef24fae812e0a2721ed392e968.tar.gz
nixlib-ececaafee17dcdef24fae812e0a2721ed392e968.tar.bz2
nixlib-ececaafee17dcdef24fae812e0a2721ed392e968.tar.lz
nixlib-ececaafee17dcdef24fae812e0a2721ed392e968.tar.xz
nixlib-ececaafee17dcdef24fae812e0a2721ed392e968.tar.zst
nixlib-ececaafee17dcdef24fae812e0a2721ed392e968.zip
rootston module: better defaults
Diffstat (limited to 'nixos/modules/programs/rootston.nix')
-rw-r--r--nixos/modules/programs/rootston.nix25
1 files changed, 20 insertions, 5 deletions
diff --git a/nixos/modules/programs/rootston.nix b/nixos/modules/programs/rootston.nix
index a8fe2b22be57..c2ae01e5270c 100644
--- a/nixos/modules/programs/rootston.nix
+++ b/nixos/modules/programs/rootston.nix
@@ -10,6 +10,7 @@ let
     if [[ "$#" -ge 1 ]]; then
       exec ${pkgs.rootston}/bin/rootston "$@"
     else
+      ${cfg.extraSessionCommands}
       exec ${pkgs.rootston}/bin/rootston -C ${cfg.configFile}
     fi
   '';
@@ -21,14 +22,28 @@ in {
       Wayland compositor you should e.g. use Sway instead). You can manually
       start the compositor by running "rootston" from a terminal'';
 
+    extraSessionCommands = mkOption {
+      type = types.lines;
+      default = "";
+      example = ''
+        # Define a keymap (US QWERTY is the default)
+        export XKB_DEFAULT_LAYOUT=de,us
+        export XKB_DEFAULT_VARIANT=nodeadkeys
+        export XKB_DEFAULT_OPTIONS=grp:alt_shift_toggle,caps:escape
+      '';
+      description = ''
+        Shell commands executed just before rootston is started.
+      '';
+    };
+
     extraPackages = mkOption {
       type = with types; listOf package;
       default = with pkgs; [
-        xwayland rxvt_unicode dmenu
+        westonLite xwayland rofi
       ];
       defaultText = literalExample ''
         with pkgs; [
-          xwayland dmenu rxvt_unicode
+          westonLite xwayland rofi
         ]
       '';
       example = literalExample "[ ]";
@@ -55,9 +70,8 @@ in {
         Logo+q = close
         Logo+m = maximize
         Alt+Tab = next_window
-        Logo+Return = exec urxvt
-        # Note: Dmenu will only work properly while e.g. urxvt is running.
-        Logo+d = exec dmenu_run
+        Logo+Return = exec weston-terminal
+        Logo+d = exec rofi -show run
       '';
       description = ''
         Default configuration for rootston (used when called without any
@@ -82,6 +96,7 @@ in {
 
     hardware.opengl.enable = mkDefault true;
     fonts.enableDefaultFonts = mkDefault true;
+    programs.dconf.enable = mkDefault true;
   };
 
   meta.maintainers = with lib.maintainers; [ primeos ];