summary refs log tree commit diff
path: root/nixos/modules/programs/oblogout.nix
diff options
context:
space:
mode:
authorromildo <malaquias@gmail.com>2017-08-24 18:10:32 -0300
committerromildo <malaquias@gmail.com>2017-08-24 18:10:32 -0300
commit51df72e4f6cdabb67e4c693f006f967aa9b4225c (patch)
treea030b7f62ab0f0b84183f86d86d9cd18cc76f74d /nixos/modules/programs/oblogout.nix
parent31ba3649ec1e6973eadaa40fe6bd42861901b3e0 (diff)
downloadnixlib-51df72e4f6cdabb67e4c693f006f967aa9b4225c.tar
nixlib-51df72e4f6cdabb67e4c693f006f967aa9b4225c.tar.gz
nixlib-51df72e4f6cdabb67e4c693f006f967aa9b4225c.tar.bz2
nixlib-51df72e4f6cdabb67e4c693f006f967aa9b4225c.tar.lz
nixlib-51df72e4f6cdabb67e4c693f006f967aa9b4225c.tar.xz
nixlib-51df72e4f6cdabb67e4c693f006f967aa9b4225c.tar.zst
nixlib-51df72e4f6cdabb67e4c693f006f967aa9b4225c.zip
oblogout: add description for configuration options
Diffstat (limited to 'nixos/modules/programs/oblogout.nix')
-rw-r--r--nixos/modules/programs/oblogout.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/nixos/modules/programs/oblogout.nix b/nixos/modules/programs/oblogout.nix
index 79a8ddb7ce37..042935d285e3 100644
--- a/nixos/modules/programs/oblogout.nix
+++ b/nixos/modules/programs/oblogout.nix
@@ -27,6 +27,7 @@ in
         type = types.int;
         default = 70;
         description = ''
+          Opacity percentage of Cairo rendered backgrounds.
         '';
       };
 
@@ -34,6 +35,7 @@ in
         type = types.str;
         default = "black";
         description = ''
+          Colour name or hex code (#ffffff) of the background color.
         '';
       };
 
@@ -41,6 +43,9 @@ in
         type = types.str;
         default = "simplistic";
         description = ''
+          Icon theme for the buttons, must be in the themes folder of
+          the package, or in
+          <filename>~/.themes/<name>/oblogout/</filename>.
         '';
       };
 
@@ -48,6 +53,7 @@ in
         type = types.str;
         default =  "cancel, logout, restart, shutdown, suspend, hibernate";
         description = ''
+          List and order of buttons to show.
         '';
       };
 
@@ -55,6 +61,7 @@ in
         type = types.str;
         default =  "Escape";
         description = ''
+          Cancel logout/shutdown shortcut.
         '';
       };
 
@@ -62,6 +69,7 @@ in
         type = types.str;
         default = "S";
         description = ''
+          Shutdown shortcut.
         '';
       };
 
@@ -69,6 +77,7 @@ in
         type = types.str;
         default = "R";
         description = ''
+          Restart shortcut.
         '';
       };
 
@@ -76,6 +85,7 @@ in
         type = types.str;
         default = "U";
         description = ''
+          Suspend shortcut.
         '';
       };
 
@@ -83,6 +93,7 @@ in
         type = types.str;
         default = "L";
         description = ''
+          Logout shortcut.
         '';
       };
 
@@ -90,6 +101,7 @@ in
         type = types.str;
         default = "K";
         description = ''
+          Lock session shortcut.
         '';
       };
 
@@ -97,6 +109,7 @@ in
         type = types.str;
         default =  "H";
         description = ''
+          Hibernate shortcut.
         '';
       };
 
@@ -104,6 +117,7 @@ in
         type = types.str;
         default = "openbox --exit";
         description = ''
+          Command to logout.
         '';
       };
 
@@ -111,6 +125,7 @@ in
         type = types.str;
         default = "";
         description = ''
+          Command to lock screen.
         '';
       };
 
@@ -118,6 +133,7 @@ in
         type = types.str;
         default = "";
         description = ''
+          Command to switch user.
         '';
       };
     };