summary refs log tree commit diff
path: root/nixos/modules/programs/gphoto2.nix
diff options
context:
space:
mode:
authorChristopher League <league@contrapunctus.net>2016-12-27 13:39:53 -0500
committerChristopher League <league@contrapunctus.net>2016-12-27 17:47:38 -0500
commit6eead52e1252413ea835fa1261bbf73ff569d23d (patch)
treefedfb30ca32a4ce4c0a12dd2c0fb3e3ff27c997a /nixos/modules/programs/gphoto2.nix
parent02c65bdac919fcb0cecc1a157744156ed39b9fc6 (diff)
downloadnixlib-6eead52e1252413ea835fa1261bbf73ff569d23d.tar
nixlib-6eead52e1252413ea835fa1261bbf73ff569d23d.tar.gz
nixlib-6eead52e1252413ea835fa1261bbf73ff569d23d.tar.bz2
nixlib-6eead52e1252413ea835fa1261bbf73ff569d23d.tar.lz
nixlib-6eead52e1252413ea835fa1261bbf73ff569d23d.tar.xz
nixlib-6eead52e1252413ea835fa1261bbf73ff569d23d.tar.zst
nixlib-6eead52e1252413ea835fa1261bbf73ff569d23d.zip
gphoto2: nixos programs module to configure udev
Closes #21420.
Diffstat (limited to 'nixos/modules/programs/gphoto2.nix')
-rw-r--r--nixos/modules/programs/gphoto2.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/nixos/modules/programs/gphoto2.nix b/nixos/modules/programs/gphoto2.nix
new file mode 100644
index 000000000000..47822562aee1
--- /dev/null
+++ b/nixos/modules/programs/gphoto2.nix
@@ -0,0 +1,31 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+{
+  meta.maintainers = [ maintainers.league ];
+
+  ###### interface
+  options = {
+    programs.gphoto2 = {
+      enable = mkOption {
+        default = false;
+        example = true;
+        type = types.bool;
+        description = ''
+          Whether to configure system to use gphoto2.
+          To grant digital camera access to a user, the user must
+          be part of the camera group:
+          <code>users.extraUsers.alice.extraGroups = ["camera"];</code>
+        '';
+      };
+    };
+  };
+
+  ###### implementation
+  config = mkIf config.programs.gphoto2.enable {
+    services.udev.packages = [ pkgs.libgphoto2 ];
+    environment.systemPackages = [ pkgs.gphoto2 ];
+    users.extraGroups.camera = {};
+  };
+}