summary refs log tree commit diff
path: root/nixos/modules/profiles/qemu-guest.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2014-03-30 16:52:56 +0200
committerEelco Dolstra <eelco.dolstra@logicblox.com>2014-03-30 16:53:23 +0200
commit1c192e1feac0572ecad7801d8b0311dbc7ecbdbc (patch)
tree088abe206afd0eab23069df6fc4a3821afa7f4c7 /nixos/modules/profiles/qemu-guest.nix
parentc394d4079d65d9af5145c7d253bb5d18e3c2a451 (diff)
downloadnixlib-1c192e1feac0572ecad7801d8b0311dbc7ecbdbc.tar
nixlib-1c192e1feac0572ecad7801d8b0311dbc7ecbdbc.tar.gz
nixlib-1c192e1feac0572ecad7801d8b0311dbc7ecbdbc.tar.bz2
nixlib-1c192e1feac0572ecad7801d8b0311dbc7ecbdbc.tar.lz
nixlib-1c192e1feac0572ecad7801d8b0311dbc7ecbdbc.tar.xz
nixlib-1c192e1feac0572ecad7801d8b0311dbc7ecbdbc.tar.zst
nixlib-1c192e1feac0572ecad7801d8b0311dbc7ecbdbc.zip
Another attempt to fix the installer test
http://hydra.nixos.org/build/9904133
Diffstat (limited to 'nixos/modules/profiles/qemu-guest.nix')
-rw-r--r--nixos/modules/profiles/qemu-guest.nix10
1 files changed, 9 insertions, 1 deletions
diff --git a/nixos/modules/profiles/qemu-guest.nix b/nixos/modules/profiles/qemu-guest.nix
index c8e6fd4aa768..0a92b7ace507 100644
--- a/nixos/modules/profiles/qemu-guest.nix
+++ b/nixos/modules/profiles/qemu-guest.nix
@@ -5,5 +5,13 @@
 
 {
   boot.initrd.availableKernelModules = [ "virtio_net" "virtio_pci" "virtio_blk" "9p" "9pnet_virtio" ];
-  boot.kernelModules = [ "virtio_balloon" "virtio_console" ];
+  boot.initrd.kernelModules = [ "virtio_balloon" "virtio_console" ];
+
+  boot.initrd.postDeviceCommands =
+    ''
+      # Set the system time from the hardware clock to work around a
+      # bug in qemu-kvm > 1.5.2 (where the VM clock is initialised
+      # to the *boot time* of the host).
+      hwclock -s
+    '';
 }