summary refs log tree commit diff
path: root/nixos/modules/module-list.nix
diff options
context:
space:
mode:
authorMaximilian Bosch <maximilian@mbosch.me>2018-06-10 23:08:50 +0200
committerxeji <36407913+xeji@users.noreply.github.com>2018-06-10 23:08:50 +0200
commitaa46b1ec0ecb498716813549fe4de479b8f5e893 (patch)
treefeaa56a454ec05534b85292ab79d70a41638fb2e /nixos/modules/module-list.nix
parent35ce5c1c8e5228f43cde083f897ac9da9f24031c (diff)
downloadnixlib-aa46b1ec0ecb498716813549fe4de479b8f5e893.tar
nixlib-aa46b1ec0ecb498716813549fe4de479b8f5e893.tar.gz
nixlib-aa46b1ec0ecb498716813549fe4de479b8f5e893.tar.bz2
nixlib-aa46b1ec0ecb498716813549fe4de479b8f5e893.tar.lz
nixlib-aa46b1ec0ecb498716813549fe4de479b8f5e893.tar.xz
nixlib-aa46b1ec0ecb498716813549fe4de479b8f5e893.tar.zst
nixlib-aa46b1ec0ecb498716813549fe4de479b8f5e893.zip
nixos/autosuggestions: add module (#41397)
The `zsh-autosuggestions` package provides several configuration options
such as a different highlight style (like `fg=cyan` which is easier to
read).

With `rename.nix` the old `programs.zsh.enableAutosuggestions` is still
functional, but yields the following warning like this during evaluation:

```
trace: warning: The option `programs.zsh.enableAutosuggestions' defined in `<unknown-file>' has been renamed to `programs.zsh.autosuggestions.enable'.
```

The module provides the most common `zsh-autosuggestions` (highlight
style and strategy) as options that will be written into the interactive
shell init (`/etc/zshrc` by default). Further configuration options can
be declared using the `extraConfig` attr set:

```
{
  programs.zsh.autosuggestions.extraConfig = {
    "ZSH_AUTOSUGGEST_BUFFER_MAX_SIZE" = "buffer_size";
  };
}
```

A full list of available configuration options for `zsh-autosuggestions`
can be viewed here: https://github.com/zsh-users/zsh-autosuggestions/blob/v0.4.3/README.md
Diffstat (limited to 'nixos/modules/module-list.nix')
-rw-r--r--nixos/modules/module-list.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/nixos/modules/module-list.nix b/nixos/modules/module-list.nix
index da4c21296ffd..71e0bf1461f3 100644
--- a/nixos/modules/module-list.nix
+++ b/nixos/modules/module-list.nix
@@ -127,6 +127,7 @@
   ./programs/zsh/oh-my-zsh.nix
   ./programs/zsh/zsh.nix
   ./programs/zsh/zsh-autoenv.nix
+  ./programs/zsh/zsh-autosuggestions.nix
   ./programs/zsh/zsh-syntax-highlighting.nix
   ./rename.nix
   ./security/acme.nix