summary refs log tree commit diff
path: root/nixos/modules/module-list.nix
diff options
context:
space:
mode:
authorMaximilian Bosch <maximilian@mbosch.me>2018-05-18 18:24:53 +0200
committerxeji <36407913+xeji@users.noreply.github.com>2018-05-18 18:24:53 +0200
commit641a62305305692c294ab3f67c597bc90067a667 (patch)
treeb009c144a626941263dc36219128796762be809d /nixos/modules/module-list.nix
parentcfc016c7cd2059eb389f14c2cff7ede19a8d8d64 (diff)
downloadnixlib-641a62305305692c294ab3f67c597bc90067a667.tar
nixlib-641a62305305692c294ab3f67c597bc90067a667.tar.gz
nixlib-641a62305305692c294ab3f67c597bc90067a667.tar.bz2
nixlib-641a62305305692c294ab3f67c597bc90067a667.tar.lz
nixlib-641a62305305692c294ab3f67c597bc90067a667.tar.xz
nixlib-641a62305305692c294ab3f67c597bc90067a667.tar.zst
nixlib-641a62305305692c294ab3f67c597bc90067a667.zip
nixos/xss-lock: add module (#40619)
`xsslock` (which was originally packaged in 6cb1d1aaaf02a72329bedf9c6960e54fea6f5c6e)
is a simple screensaver which connects a given screen locker (e.g.
`i3lock`) with `logind`. Whenever `loginctl lock-sessions` is invoked
the locker will be used to lock the screen. This works with its power
management features (e.g. `lid switch`) as well, so the PC can be locked
automatically when the lid is closed.

The module can be used like this:

```
{
  services.xserver.enable = true;

  programs.xss-lock.enable = true;
  programs.xss-lock.lockerCommand = "i3lock";
}
```
Diffstat (limited to 'nixos/modules/module-list.nix')
-rw-r--r--nixos/modules/module-list.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/nixos/modules/module-list.nix b/nixos/modules/module-list.nix
index 6fe29af3a00d..d5cfd87520c5 100644
--- a/nixos/modules/module-list.nix
+++ b/nixos/modules/module-list.nix
@@ -122,6 +122,7 @@
   ./programs/wireshark.nix
   ./programs/xfs_quota.nix
   ./programs/xonsh.nix
+  ./programs/xss-lock.nix
   ./programs/yabar.nix
   ./programs/zsh/oh-my-zsh.nix
   ./programs/zsh/zsh.nix