summary refs log tree commit diff
path: root/nixos/modules/misc/passthru.nix
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2014-05-05 14:58:51 -0400
committerShea Levy <shea@shealevy.com>2014-07-02 12:28:18 -0400
commitb3cfb9084b3860852581be235aea90540a5302d4 (patch)
tree06cf1333ae7d60f25bd23866dbaec17b148a15dd /nixos/modules/misc/passthru.nix
parent80709b141ca82d5afe3874f50b822db3409bed4e (diff)
downloadnixlib-b3cfb9084b3860852581be235aea90540a5302d4.tar
nixlib-b3cfb9084b3860852581be235aea90540a5302d4.tar.gz
nixlib-b3cfb9084b3860852581be235aea90540a5302d4.tar.bz2
nixlib-b3cfb9084b3860852581be235aea90540a5302d4.tar.lz
nixlib-b3cfb9084b3860852581be235aea90540a5302d4.tar.xz
nixlib-b3cfb9084b3860852581be235aea90540a5302d4.tar.zst
nixlib-b3cfb9084b3860852581be235aea90540a5302d4.zip
Get all lib functions from lib, not pkgs.lib, in modules
Diffstat (limited to 'nixos/modules/misc/passthru.nix')
-rw-r--r--nixos/modules/misc/passthru.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nixos/modules/misc/passthru.nix b/nixos/modules/misc/passthru.nix
index b65f20d62f2d..f3c9f6ba651b 100644
--- a/nixos/modules/misc/passthru.nix
+++ b/nixos/modules/misc/passthru.nix
@@ -1,11 +1,11 @@
 # This module allows you to export something from configuration
 # Use case: export kernel source expression for ease of configuring
 
-{ config, pkgs, ... }:
+{ config, lib, ... }:
 
 {
   options = {
-    passthru = pkgs.lib.mkOption {
+    passthru = lib.mkOption {
       visible = false;
       description = ''
         This attribute set will be exported as a system attribute.