summary refs log tree commit diff
path: root/nixos/modules/misc/crashdump.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-30 17:37:45 +0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-30 18:47:43 +0100
commit408b8b5725c3e6fff75aef772da248d3e95ff414 (patch)
tree692e3b61dbbff85cc97e3becf13a1376dea04a92 /nixos/modules/misc/crashdump.nix
parentd882e1966251880240599d3c1b31e060661506ee (diff)
downloadnixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.tar
nixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.tar.gz
nixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.tar.bz2
nixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.tar.lz
nixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.tar.xz
nixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.tar.zst
nixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.zip
Add lots of missing option types
Diffstat (limited to 'nixos/modules/misc/crashdump.nix')
-rw-r--r--nixos/modules/misc/crashdump.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/nixos/modules/misc/crashdump.nix b/nixos/modules/misc/crashdump.nix
index 6e6bc9dec0f3..6e71baa9a431 100644
--- a/nixos/modules/misc/crashdump.nix
+++ b/nixos/modules/misc/crashdump.nix
@@ -14,8 +14,8 @@ in
     boot = {
       crashDump = {
         enable = mkOption {
+          type = types.bool;
           default = false;
-          example = true;
           description = ''
             If enabled, NixOS will set up a kernel that will
             boot on crash, and leave the user to a stage1 debug1devices
@@ -35,6 +35,7 @@ in
           '';
         };
         kernelParams = mkOption {
+          type = types.listOf types.str;
           default = [ "debug1devices" ];
           description = ''
             Parameters that will be passed to the kernel kexec-ed on crash.