summary refs log tree commit diff
path: root/nixos/modules/installer/cd-dvd/iso-image.nix
diff options
context:
space:
mode:
authorJan Malakhovski <oxij@oxij.org>2015-09-18 16:50:48 +0000
committerJan Malakhovski <oxij@oxij.org>2016-01-08 22:26:15 +0000
commit119c8f91e7f17d2cb95f42985816820600c389cf (patch)
tree0bd34b6a522114777f34668fb6d6c36c331eaea1 /nixos/modules/installer/cd-dvd/iso-image.nix
parent732eb3c4ccaac3312fe9334b5d77b3b88140c971 (diff)
downloadnixlib-119c8f91e7f17d2cb95f42985816820600c389cf.tar
nixlib-119c8f91e7f17d2cb95f42985816820600c389cf.tar.gz
nixlib-119c8f91e7f17d2cb95f42985816820600c389cf.tar.bz2
nixlib-119c8f91e7f17d2cb95f42985816820600c389cf.tar.lz
nixlib-119c8f91e7f17d2cb95f42985816820600c389cf.tar.xz
nixlib-119c8f91e7f17d2cb95f42985816820600c389cf.tar.zst
nixlib-119c8f91e7f17d2cb95f42985816820600c389cf.zip
nixos: introduce system.nixosLabel option and use it where appropriate
Setting nixosVersion to something custom is useful for meaningful GRUB
menus and /nix/store paths, but actuallly changing it rebulids the
whole system path (because of `nixos-version` script and manual
pages). Also, changing it is not a particularly good idea because you
can then be differentitated from other NixOS users by a lot of
programs that read /etc/os-release.

This patch introduces an alternative option that does all you want
from nixosVersion, but rebuilds only the very top system level and
/etc while using your label in the names of system /nix/store paths,
GRUB and other boot loaders' menus, getty greetings and so on.
Diffstat (limited to 'nixos/modules/installer/cd-dvd/iso-image.nix')
-rw-r--r--nixos/modules/installer/cd-dvd/iso-image.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/installer/cd-dvd/iso-image.nix b/nixos/modules/installer/cd-dvd/iso-image.nix
index fa9cc6fa20b9..b79191e0fd4b 100644
--- a/nixos/modules/installer/cd-dvd/iso-image.nix
+++ b/nixos/modules/installer/cd-dvd/iso-image.nix
@@ -39,7 +39,7 @@ let
     DEFAULT boot
 
     LABEL boot
-    MENU LABEL NixOS ${config.system.nixosVersion}${config.isoImage.appendToMenuLabel}
+    MENU LABEL NixOS ${config.system.nixosLabel}${config.isoImage.appendToMenuLabel}
     LINUX /boot/bzImage
     APPEND init=${config.system.build.toplevel}/init ${toString config.boot.kernelParams}
     INITRD /boot/initrd