summary refs log tree commit diff
path: root/nixos/modules/hardware/opengl.nix
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2014-06-15 19:15:48 +0200
committerVladimír Čunát <vcunat@gmail.com>2014-06-15 19:18:16 +0200
commitde783277da66e38ae62794cff90d758b272fcf6c (patch)
treea1968f8d823eb2d5e95a08453aca161676a8001e /nixos/modules/hardware/opengl.nix
parent43a77448f845817d7643f42c11fda642c1e9ec57 (diff)
downloadnixlib-de783277da66e38ae62794cff90d758b272fcf6c.tar
nixlib-de783277da66e38ae62794cff90d758b272fcf6c.tar.gz
nixlib-de783277da66e38ae62794cff90d758b272fcf6c.tar.bz2
nixlib-de783277da66e38ae62794cff90d758b272fcf6c.tar.lz
nixlib-de783277da66e38ae62794cff90d758b272fcf6c.tar.xz
nixlib-de783277da66e38ae62794cff90d758b272fcf6c.tar.zst
nixlib-de783277da66e38ae62794cff90d758b272fcf6c.zip
nixos/opengl: add LD_LIBRARY_PATH to systemVariables instead
so all users get this variable, thanks to work from #2692.
Diffstat (limited to 'nixos/modules/hardware/opengl.nix')
-rw-r--r--nixos/modules/hardware/opengl.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nixos/modules/hardware/opengl.nix b/nixos/modules/hardware/opengl.nix
index 096f7e2c0970..7778c3f5409f 100644
--- a/nixos/modules/hardware/opengl.nix
+++ b/nixos/modules/hardware/opengl.nix
@@ -16,7 +16,7 @@ let
       [ p.mesa_drivers
         p.mesa_noglu # mainly for libGL
         (if cfg.s3tcSupport then p.libtxc_dxtn else p.libtxc_dxtn_s2tc)
-	p.udev
+        p.udev
       ];
   };
 
@@ -101,7 +101,7 @@ in
         ''}
       '';
 
-    environment.variables.LD_LIBRARY_PATH =
+    environment.systemVariables.LD_LIBRARY_PATH =
       [ "/run/opengl-driver/lib" "/run/opengl-driver-32/lib" ];
 
     # FIXME: move this into card-specific modules.