summary refs log tree commit diff
path: root/nixos/modules/hardware/opengl.nix
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2014-05-05 14:58:51 -0400
committerShea Levy <shea@shealevy.com>2014-07-02 12:28:18 -0400
commitb3cfb9084b3860852581be235aea90540a5302d4 (patch)
tree06cf1333ae7d60f25bd23866dbaec17b148a15dd /nixos/modules/hardware/opengl.nix
parent80709b141ca82d5afe3874f50b822db3409bed4e (diff)
downloadnixlib-b3cfb9084b3860852581be235aea90540a5302d4.tar
nixlib-b3cfb9084b3860852581be235aea90540a5302d4.tar.gz
nixlib-b3cfb9084b3860852581be235aea90540a5302d4.tar.bz2
nixlib-b3cfb9084b3860852581be235aea90540a5302d4.tar.lz
nixlib-b3cfb9084b3860852581be235aea90540a5302d4.tar.xz
nixlib-b3cfb9084b3860852581be235aea90540a5302d4.tar.zst
nixlib-b3cfb9084b3860852581be235aea90540a5302d4.zip
Get all lib functions from lib, not pkgs.lib, in modules
Diffstat (limited to 'nixos/modules/hardware/opengl.nix')
-rw-r--r--nixos/modules/hardware/opengl.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/hardware/opengl.nix b/nixos/modules/hardware/opengl.nix
index ab5c309bd422..f894c830eb6c 100644
--- a/nixos/modules/hardware/opengl.nix
+++ b/nixos/modules/hardware/opengl.nix
@@ -84,7 +84,7 @@ in
 
   config = mkIf cfg.enable {
 
-    assertions = pkgs.lib.singleton {
+    assertions = lib.singleton {
       assertion = cfg.driSupport32Bit -> pkgs.stdenv.isx86_64;
       message = "Option driSupport32Bit only makes sense on a 64-bit system.";
     };