summary refs log tree commit diff
path: root/nixos/modules/hardware/network/intel-2200bg.nix
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2014-05-05 14:58:51 -0400
committerShea Levy <shea@shealevy.com>2014-07-02 12:28:18 -0400
commitb3cfb9084b3860852581be235aea90540a5302d4 (patch)
tree06cf1333ae7d60f25bd23866dbaec17b148a15dd /nixos/modules/hardware/network/intel-2200bg.nix
parent80709b141ca82d5afe3874f50b822db3409bed4e (diff)
downloadnixlib-b3cfb9084b3860852581be235aea90540a5302d4.tar
nixlib-b3cfb9084b3860852581be235aea90540a5302d4.tar.gz
nixlib-b3cfb9084b3860852581be235aea90540a5302d4.tar.bz2
nixlib-b3cfb9084b3860852581be235aea90540a5302d4.tar.lz
nixlib-b3cfb9084b3860852581be235aea90540a5302d4.tar.xz
nixlib-b3cfb9084b3860852581be235aea90540a5302d4.tar.zst
nixlib-b3cfb9084b3860852581be235aea90540a5302d4.zip
Get all lib functions from lib, not pkgs.lib, in modules
Diffstat (limited to 'nixos/modules/hardware/network/intel-2200bg.nix')
-rw-r--r--nixos/modules/hardware/network/intel-2200bg.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/nixos/modules/hardware/network/intel-2200bg.nix b/nixos/modules/hardware/network/intel-2200bg.nix
index ae5b69b7981d..1b70057d135b 100644
--- a/nixos/modules/hardware/network/intel-2200bg.nix
+++ b/nixos/modules/hardware/network/intel-2200bg.nix
@@ -1,4 +1,4 @@
-{ config, pkgs, ... }:
+{ config, pkgs, lib, ... }:
 
 {
 
@@ -6,9 +6,9 @@
 
   options = {
 
-    networking.enableIntel2200BGFirmware = pkgs.lib.mkOption {
+    networking.enableIntel2200BGFirmware = lib.mkOption {
       default = false;
-      type = pkgs.lib.types.bool;
+      type = lib.types.bool;
       description = ''
         Turn on this option if you want firmware for the Intel
         PRO/Wireless 2200BG to be loaded automatically.  This is
@@ -21,7 +21,7 @@
 
   ###### implementation
 
-  config = pkgs.lib.mkIf config.networking.enableIntel2200BGFirmware {
+  config = lib.mkIf config.networking.enableIntel2200BGFirmware {
 
     hardware.enableAllFirmware = true;