summary refs log tree commit diff
path: root/nixos/modules/config/vpnc.nix
diff options
context:
space:
mode:
authorLeroy Hopson <git@leroy.geek.nz>2015-07-04 18:48:27 +1200
committerLeroy Hopson <git@leroy.geek.nz>2016-02-27 22:25:39 +1300
commit3e326efffcf962a3d60d169bf18e0ad515fe7dee (patch)
treeb41a9129b4396f595584d9b14b0088d1253007f1 /nixos/modules/config/vpnc.nix
parenta8b44c74d351a60c7b6c7e30d8b62b85aaa00f94 (diff)
downloadnixlib-3e326efffcf962a3d60d169bf18e0ad515fe7dee.tar
nixlib-3e326efffcf962a3d60d169bf18e0ad515fe7dee.tar.gz
nixlib-3e326efffcf962a3d60d169bf18e0ad515fe7dee.tar.bz2
nixlib-3e326efffcf962a3d60d169bf18e0ad515fe7dee.tar.lz
nixlib-3e326efffcf962a3d60d169bf18e0ad515fe7dee.tar.xz
nixlib-3e326efffcf962a3d60d169bf18e0ad515fe7dee.tar.zst
nixlib-3e326efffcf962a3d60d169bf18e0ad515fe7dee.zip
nixos/vpnc: fix formatting of example
Diffstat (limited to 'nixos/modules/config/vpnc.nix')
-rw-r--r--nixos/modules/config/vpnc.nix20
1 files changed, 10 insertions, 10 deletions
diff --git a/nixos/modules/config/vpnc.nix b/nixos/modules/config/vpnc.nix
index 68d755232ebe..c7ac1b3530e1 100644
--- a/nixos/modules/config/vpnc.nix
+++ b/nixos/modules/config/vpnc.nix
@@ -17,16 +17,16 @@ in
       services = mkOption {
        type = types.attrsOf types.str;
        default = {};
-       example = {
-         test = 
-          ''
-           IPSec gateway 192.168.1.1 
-           IPSec ID someID
-           IPSec secret secretKey
-           Xauth username name
-           Xauth password pass
-          '';
-       };
+       example = literalExample ''
+         { test = '''
+             IPSec gateway 192.168.1.1
+             IPSec ID someID
+             IPSec secret secretKey
+             Xauth username name
+             Xauth password pass
+           ''';
+         }
+       '';
        description = 
          ''
            The names of cisco VPNs and their associated definitions