summary refs log tree commit diff
path: root/nixos/modules/config/users-groups.nix
diff options
context:
space:
mode:
authorThomas Strobel <ts468@cam.ac.uk>2015-07-02 16:46:56 +0200
committerThomas Strobel <ts468@cam.ac.uk>2015-07-04 23:42:31 +0200
commit7b6f2791424d6b1a70ffab8b91783df1a2a8fc5a (patch)
tree62a8e6f8fd6a7836c14789cefd7c3dbd13192a32 /nixos/modules/config/users-groups.nix
parenta5360c5b6edd150673b29b90f95e0eee840d6766 (diff)
downloadnixlib-7b6f2791424d6b1a70ffab8b91783df1a2a8fc5a.tar
nixlib-7b6f2791424d6b1a70ffab8b91783df1a2a8fc5a.tar.gz
nixlib-7b6f2791424d6b1a70ffab8b91783df1a2a8fc5a.tar.bz2
nixlib-7b6f2791424d6b1a70ffab8b91783df1a2a8fc5a.tar.lz
nixlib-7b6f2791424d6b1a70ffab8b91783df1a2a8fc5a.tar.xz
nixlib-7b6f2791424d6b1a70ffab8b91783df1a2a8fc5a.tar.zst
nixlib-7b6f2791424d6b1a70ffab8b91783df1a2a8fc5a.zip
pam_mount module: integrate pam_mount into PAM of NixOS
Diffstat (limited to 'nixos/modules/config/users-groups.nix')
-rw-r--r--nixos/modules/config/users-groups.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/nixos/modules/config/users-groups.nix b/nixos/modules/config/users-groups.nix
index 9d48edf2f26c..478f433b431c 100644
--- a/nixos/modules/config/users-groups.nix
+++ b/nixos/modules/config/users-groups.nix
@@ -108,6 +108,15 @@ let
         description = "The user's home directory.";
       };
 
+      cryptHomeLuks = mkOption {
+        type = with types; nullOr str;
+        default = null;
+        description = ''
+          Path to encrypted luks device that contains
+          the user's home directory.
+        '';
+      };
+
       shell = mkOption {
         type = types.str;
         default = "/run/current-system/sw/bin/nologin";