summary refs log tree commit diff
path: root/nixos/modules/config/unix-odbc-drivers.nix
diff options
context:
space:
mode:
authorThomas Strobel <ts468@cam.ac.uk>2016-01-17 19:34:55 +0100
committerThomas Strobel <ts468@cam.ac.uk>2016-01-17 19:41:23 +0100
commita04a7272aa38ada45e694281071b720d4abbd0df (patch)
tree3cd20fafec2de8e3b5ec558461a779898b4e50ee /nixos/modules/config/unix-odbc-drivers.nix
parentae5ef2b00955a8b8cbcc93a6682a8275c4d5e52c (diff)
downloadnixlib-a04a7272aa38ada45e694281071b720d4abbd0df.tar
nixlib-a04a7272aa38ada45e694281071b720d4abbd0df.tar.gz
nixlib-a04a7272aa38ada45e694281071b720d4abbd0df.tar.bz2
nixlib-a04a7272aa38ada45e694281071b720d4abbd0df.tar.lz
nixlib-a04a7272aa38ada45e694281071b720d4abbd0df.tar.xz
nixlib-a04a7272aa38ada45e694281071b720d4abbd0df.tar.zst
nixlib-a04a7272aa38ada45e694281071b720d4abbd0df.zip
Add missing 'type', 'defaultText' and 'literalExample' in module definitions
- add missing types in module definitions
- add missing 'defaultText' in module definitions
- wrap example with 'literalExample' where necessary in module definitions
Diffstat (limited to 'nixos/modules/config/unix-odbc-drivers.nix')
-rw-r--r--nixos/modules/config/unix-odbc-drivers.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/nixos/modules/config/unix-odbc-drivers.nix b/nixos/modules/config/unix-odbc-drivers.nix
index 98929392acec..eea6477fff23 100644
--- a/nixos/modules/config/unix-odbc-drivers.nix
+++ b/nixos/modules/config/unix-odbc-drivers.nix
@@ -10,8 +10,9 @@ with lib;
 
   options = {
     environment.unixODBCDrivers = mkOption {
+      type = types.listOf types.package;
       default = [];
-      example = literalExample "map (x : x.ini) (with pkgs.unixODBCDrivers; [ mysql psql psqlng ] )";
+      example = literalExample "with pkgs.unixODBCDrivers; [ mysql psql psqlng ]";
       description = ''
         Specifies Unix ODBC drivers to be registered in
         <filename>/etc/odbcinst.ini</filename>.  You may also want to
@@ -26,7 +27,7 @@ with lib;
   config = mkIf (config.environment.unixODBCDrivers != []) {
 
     environment.etc."odbcinst.ini".text =
-      let inis = config.environment.unixODBCDrivers;
+      let inis = map (x : x.ini) config.environment.unixODBCDrivers;
       in lib.concatStringsSep "\n" inis;
 
   };