summary refs log tree commit diff
path: root/nixos/modules/config/system-path.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-30 14:18:41 +0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-30 14:57:42 +0100
commit4680af6a9334297885a96ba464d58316587a87fd (patch)
tree25b52f21c8cf328b793174823635179d9aa65dff /nixos/modules/config/system-path.nix
parentc7f7ceefd68e3f0204377c5818539bec35330765 (diff)
downloadnixlib-4680af6a9334297885a96ba464d58316587a87fd.tar
nixlib-4680af6a9334297885a96ba464d58316587a87fd.tar.gz
nixlib-4680af6a9334297885a96ba464d58316587a87fd.tar.bz2
nixlib-4680af6a9334297885a96ba464d58316587a87fd.tar.lz
nixlib-4680af6a9334297885a96ba464d58316587a87fd.tar.xz
nixlib-4680af6a9334297885a96ba464d58316587a87fd.tar.zst
nixlib-4680af6a9334297885a96ba464d58316587a87fd.zip
Add some option types
Diffstat (limited to 'nixos/modules/config/system-path.nix')
-rw-r--r--nixos/modules/config/system-path.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/nixos/modules/config/system-path.nix b/nixos/modules/config/system-path.nix
index 8dd92dd96af9..932e4ccca050 100644
--- a/nixos/modules/config/system-path.nix
+++ b/nixos/modules/config/system-path.nix
@@ -60,6 +60,7 @@ in
     environment = {
 
       systemPackages = mkOption {
+        type = types.listOf types.path;
         default = [];
         example = "[ pkgs.icecat3 pkgs.thunderbird ]";
         description = ''
@@ -74,6 +75,7 @@ in
       };
 
       pathsToLink = mkOption {
+        type = types.listOf types.str;
         # Note: We need `/lib' to be among `pathsToLink' for NSS modules
         # to work.
         default = [];