summary refs log tree commit diff
path: root/nixos/modules/config/sysctl.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-28 19:48:30 +0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-28 22:45:57 +0100
commit73f32d03758a53ad1baac31795cfd99e325032f3 (patch)
tree8df21c7319e758a85a4916890714b0d90c631a67 /nixos/modules/config/sysctl.nix
parentdbefab9cf42c09444dd2554380104096969c0728 (diff)
downloadnixlib-73f32d03758a53ad1baac31795cfd99e325032f3.tar
nixlib-73f32d03758a53ad1baac31795cfd99e325032f3.tar.gz
nixlib-73f32d03758a53ad1baac31795cfd99e325032f3.tar.bz2
nixlib-73f32d03758a53ad1baac31795cfd99e325032f3.tar.lz
nixlib-73f32d03758a53ad1baac31795cfd99e325032f3.tar.xz
nixlib-73f32d03758a53ad1baac31795cfd99e325032f3.tar.zst
nixlib-73f32d03758a53ad1baac31795cfd99e325032f3.zip
Show precise error messages in option merge failures
For instance, if time.timeZone is defined multiple times, you now get
the error message:

  error: user-thrown exception: The unique option `time.timeZone' is defined multiple times, in `/etc/nixos/configurations/misc/eelco/x11vnc.nix' and `/etc/nixos/configuration.nix'.

while previously you got:

  error: user-thrown exception: Multiple definitions of string. Only one is allowed for this option.

and only an inspection of the stack trace gave a clue as to what
option caused the problem.
Diffstat (limited to 'nixos/modules/config/sysctl.nix')
-rw-r--r--nixos/modules/config/sysctl.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/modules/config/sysctl.nix b/nixos/modules/config/sysctl.nix
index 6b52fd38fdec..a825144e466b 100644
--- a/nixos/modules/config/sysctl.nix
+++ b/nixos/modules/config/sysctl.nix
@@ -7,7 +7,7 @@ let
   sysctlOption = mkOptionType {
     name = "sysctl option value";
     check = x: builtins.isBool x || builtins.isString x || builtins.isInt x;
-    merge = xs: last xs; # FIXME: hacky way to allow overriding in configuration.nix.
+    merge = args: xs: last xs; # FIXME: hacky way to allow overriding in configuration.nix.
   };
 
 in