summary refs log tree commit diff
path: root/nixos/modules/config/shells-environment.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2013-11-12 13:48:19 +0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2013-11-12 13:48:30 +0100
commit785eaf2cea3c57daef96bb209f44589e3f48a7ff (patch)
tree3324d7de769b7a5c063107b09b294b6af2b823e1 /nixos/modules/config/shells-environment.nix
parent39e9fabae0fe5476ad682a52dba42b2c6dbe1a57 (diff)
downloadnixlib-785eaf2cea3c57daef96bb209f44589e3f48a7ff.tar
nixlib-785eaf2cea3c57daef96bb209f44589e3f48a7ff.tar.gz
nixlib-785eaf2cea3c57daef96bb209f44589e3f48a7ff.tar.bz2
nixlib-785eaf2cea3c57daef96bb209f44589e3f48a7ff.tar.lz
nixlib-785eaf2cea3c57daef96bb209f44589e3f48a7ff.tar.xz
nixlib-785eaf2cea3c57daef96bb209f44589e3f48a7ff.tar.zst
nixlib-785eaf2cea3c57daef96bb209f44589e3f48a7ff.zip
Add some primops to lib
Diffstat (limited to 'nixos/modules/config/shells-environment.nix')
-rw-r--r--nixos/modules/config/shells-environment.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nixos/modules/config/shells-environment.nix b/nixos/modules/config/shells-environment.nix
index e3fbdd7aaec1..0b4f75a35216 100644
--- a/nixos/modules/config/shells-environment.nix
+++ b/nixos/modules/config/shells-environment.nix
@@ -31,9 +31,9 @@ in
             res = (head defs').value;
           in
           if isList res then concatLists (getValues defs')
-          else if builtins.lessThan 1 (length defs') then
+          else if lessThan 1 (length defs') then
             throw "The option `${showOption loc}' is defined multiple times, in ${showFiles (getFiles defs)}."
-          else if !builtins.isString res then
+          else if !isString res then
             throw "The option `${showOption loc}' does not have a string value, in ${showFiles (getFiles defs)}."
           else res;
       });