summary refs log tree commit diff
path: root/nixos/modules/config/shells-environment.nix
diff options
context:
space:
mode:
authorChristopher Birkbeck <cjpbirkbeck@gmail.com>2018-09-02 15:21:14 -0400
committerxeji <36407913+xeji@users.noreply.github.com>2018-09-02 21:21:14 +0200
commit0dd7a0f2665d6215b25ddb453dd7b51bcb40c589 (patch)
tree915e9cd040270d7aa95105b2b1d266923d9a002d /nixos/modules/config/shells-environment.nix
parent720c163a55e6d8ad1ca391bc405214ac4bc09238 (diff)
downloadnixlib-0dd7a0f2665d6215b25ddb453dd7b51bcb40c589.tar
nixlib-0dd7a0f2665d6215b25ddb453dd7b51bcb40c589.tar.gz
nixlib-0dd7a0f2665d6215b25ddb453dd7b51bcb40c589.tar.bz2
nixlib-0dd7a0f2665d6215b25ddb453dd7b51bcb40c589.tar.lz
nixlib-0dd7a0f2665d6215b25ddb453dd7b51bcb40c589.tar.xz
nixlib-0dd7a0f2665d6215b25ddb453dd7b51bcb40c589.tar.zst
nixlib-0dd7a0f2665d6215b25ddb453dd7b51bcb40c589.zip
Added an example for environment.variable. (#45956)
Diffstat (limited to 'nixos/modules/config/shells-environment.nix')
-rw-r--r--nixos/modules/config/shells-environment.nix1
1 files changed, 1 insertions, 0 deletions
diff --git a/nixos/modules/config/shells-environment.nix b/nixos/modules/config/shells-environment.nix
index b2bfc785f2a3..31adc9b82620 100644
--- a/nixos/modules/config/shells-environment.nix
+++ b/nixos/modules/config/shells-environment.nix
@@ -34,6 +34,7 @@ in
 
     environment.variables = mkOption {
       default = {};
+      example = { EDITOR = "nvim"; VISUAL = "nvim"; };
       description = ''
         A set of environment variables used in the global environment.
         These variables will be set on shell initialisation (e.g. in /etc/profile).