summary refs log tree commit diff
path: root/nixos/modules/config/pulseaudio.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-30 17:37:45 +0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-30 18:47:43 +0100
commit408b8b5725c3e6fff75aef772da248d3e95ff414 (patch)
tree692e3b61dbbff85cc97e3becf13a1376dea04a92 /nixos/modules/config/pulseaudio.nix
parentd882e1966251880240599d3c1b31e060661506ee (diff)
downloadnixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.tar
nixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.tar.gz
nixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.tar.bz2
nixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.tar.lz
nixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.tar.xz
nixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.tar.zst
nixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.zip
Add lots of missing option types
Diffstat (limited to 'nixos/modules/config/pulseaudio.nix')
-rw-r--r--nixos/modules/config/pulseaudio.nix12
1 files changed, 7 insertions, 5 deletions
diff --git a/nixos/modules/config/pulseaudio.nix b/nixos/modules/config/pulseaudio.nix
index 26060f5b2d10..7a6cc542273a 100644
--- a/nixos/modules/config/pulseaudio.nix
+++ b/nixos/modules/config/pulseaudio.nix
@@ -46,6 +46,7 @@ in {
 
     hardware.pulseaudio = {
       enable = mkOption {
+        type = types.bool;
         default = false;
         description = ''
           Whether to enable the PulseAudio sound server.
@@ -72,12 +73,13 @@ in {
           The path to the configuration the PulseAudio server
           should use. By default, the "default.pa" configuration
           from the PulseAudio distribution is used.
-        ''; 
+        '';
       };
-  
+
       package = mkOption {
+        type = types.path;
         default = pulseaudio;
-        example = "pulseaudio.override { jackaudioSupport = true; }";
+        example = literalExample "pulseaudio.override { jackaudioSupport = true; }";
         description = ''
           The PulseAudio derivation to use.  This can be used to enable
           features (such as JACK support) that are not enabled in the
@@ -125,9 +127,9 @@ in {
         description = "PulseAudio system service user";
         home = pulseRuntimePath;
       };
-  
+
       users.extraGroups.pulse.gid = gid;
-  
+
       systemd.services.pulseaudio = {
         description = "PulseAudio system-wide server";
         wantedBy = [ "sound.target" ];