summary refs log tree commit diff
path: root/nixos/modules/config/networking.nix
diff options
context:
space:
mode:
authorPeter Simons <simons@cryp.to>2017-09-23 16:36:05 +0200
committerPeter Simons <simons@cryp.to>2017-09-23 16:41:34 +0200
commit99f759de1c6c943fd747afd8fb896a0d65ae4ed8 (patch)
tree101c7c70538ea945f9196cf1d95aed70d1e1ecf4 /nixos/modules/config/networking.nix
parent3a58e41e43a80f986b1613f7db878e130d8e5d1c (diff)
downloadnixlib-99f759de1c6c943fd747afd8fb896a0d65ae4ed8.tar
nixlib-99f759de1c6c943fd747afd8fb896a0d65ae4ed8.tar.gz
nixlib-99f759de1c6c943fd747afd8fb896a0d65ae4ed8.tar.bz2
nixlib-99f759de1c6c943fd747afd8fb896a0d65ae4ed8.tar.lz
nixlib-99f759de1c6c943fd747afd8fb896a0d65ae4ed8.tar.xz
nixlib-99f759de1c6c943fd747afd8fb896a0d65ae4ed8.tar.zst
nixlib-99f759de1c6c943fd747afd8fb896a0d65ae4ed8.zip
Revert "nixos: add option for bind to not resolve local queries (#29503)"
This reverts commit 670b4e29adc16e0a29aa5b4c126703dcca56aeb6. The change
added in this commit was controversial when it was originally suggested
in https://github.com/NixOS/nixpkgs/pull/29205. Then that PR was closed
and a new one opened, https://github.com/NixOS/nixpkgs/pull/29503,
effectively circumventing the review process. I don't agree with this
modification. Adding an option 'resolveLocalQueries' to tell the locally
running name server that it should resolve local DNS queries feels
outright nuts. I agree that the current state is unsatisfactory and that
it should be improved, but this is not the right way.

(cherry picked from commit 23a021d12e8f939cd0bfddb1c7adeb125028c1e3)
Diffstat (limited to 'nixos/modules/config/networking.nix')
-rw-r--r--nixos/modules/config/networking.nix4
1 files changed, 1 insertions, 3 deletions
diff --git a/nixos/modules/config/networking.nix b/nixos/modules/config/networking.nix
index 5fa91ec9cfbc..619f36cd5150 100644
--- a/nixos/modules/config/networking.nix
+++ b/nixos/modules/config/networking.nix
@@ -9,9 +9,7 @@ let
   cfg = config.networking;
   dnsmasqResolve = config.services.dnsmasq.enable &&
                    config.services.dnsmasq.resolveLocalQueries;
-  bindResolve =    config.services.bind.enable &&
-                   config.services.bind.resolveLocalQueries;
-  hasLocalResolver = bindResolve || dnsmasqResolve;
+  hasLocalResolver = config.services.bind.enable || dnsmasqResolve;
 
   resolvconfOptions = cfg.resolvconfOptions
     ++ optional cfg.dnsSingleRequest "single-request"