summary refs log tree commit diff
path: root/nixos/modules/config/networking.nix
diff options
context:
space:
mode:
authorPeter Hoeg <peter@hoeg.com>2017-04-14 11:10:33 +0800
committerPeter Hoeg <peter@hoeg.com>2017-10-14 14:38:04 +0800
commit8758f476b36e1d98ad2c854889c642ad6d86c505 (patch)
treeda03aa91c0f060bee5eca26e77cf818d959675b8 /nixos/modules/config/networking.nix
parent0944d44f1b040856e420aad815a0d1b62194a2cb (diff)
downloadnixlib-8758f476b36e1d98ad2c854889c642ad6d86c505.tar
nixlib-8758f476b36e1d98ad2c854889c642ad6d86c505.tar.gz
nixlib-8758f476b36e1d98ad2c854889c642ad6d86c505.tar.bz2
nixlib-8758f476b36e1d98ad2c854889c642ad6d86c505.tar.lz
nixlib-8758f476b36e1d98ad2c854889c642ad6d86c505.tar.xz
nixlib-8758f476b36e1d98ad2c854889c642ad6d86c505.tar.zst
nixlib-8758f476b36e1d98ad2c854889c642ad6d86c505.zip
networking: add option to toggle the wait-online service
Diffstat (limited to 'nixos/modules/config/networking.nix')
-rw-r--r--nixos/modules/config/networking.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/nixos/modules/config/networking.nix b/nixos/modules/config/networking.nix
index 619f36cd5150..5f42ec51703c 100644
--- a/nixos/modules/config/networking.nix
+++ b/nixos/modules/config/networking.nix
@@ -186,6 +186,15 @@ in
         '';
       };
     };
+    networking.waitForOnline = lib.mkOption {
+      type = types.bool;
+      default = true;
+      description = ''
+        When bringing up the network, always wait for it to be online before continuing.
+
+        This is currently only implemented for networkd.
+      '';
+    };
   };
 
   config = {