summary refs log tree commit diff
path: root/nixos/modules/config/networking.nix
diff options
context:
space:
mode:
authorJörg Thalheim <joerg@higgsboson.tk>2016-12-14 23:49:14 +0100
committerJörg Thalheim <joerg@higgsboson.tk>2016-12-17 00:00:45 +0100
commit1590461887333e2fda46f4bd74aef3785b253089 (patch)
treecd5d6652a758dc54bffd73e9d313ba5d1d73abf1 /nixos/modules/config/networking.nix
parent993cbf8acb9da679bb8bca00eacada6d83ed6994 (diff)
downloadnixlib-1590461887333e2fda46f4bd74aef3785b253089.tar
nixlib-1590461887333e2fda46f4bd74aef3785b253089.tar.gz
nixlib-1590461887333e2fda46f4bd74aef3785b253089.tar.bz2
nixlib-1590461887333e2fda46f4bd74aef3785b253089.tar.lz
nixlib-1590461887333e2fda46f4bd74aef3785b253089.tar.xz
nixlib-1590461887333e2fda46f4bd74aef3785b253089.tar.zst
nixlib-1590461887333e2fda46f4bd74aef3785b253089.zip
ntp: make timesyncd the new default
- most nixos user only require time synchronisation,
  while ntpd implements a battery-included ntp server (1,215 LOCs of C-Code vs 64,302)
- timesyncd support ntp server per interface (if configured through dhcp for instance)
- timesyncd is already included in the systemd package, switching to it would
  save a little disk space (1,5M)
Diffstat (limited to 'nixos/modules/config/networking.nix')
-rw-r--r--nixos/modules/config/networking.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/nixos/modules/config/networking.nix b/nixos/modules/config/networking.nix
index fdc782b0579e..adc05f602314 100644
--- a/nixos/modules/config/networking.nix
+++ b/nixos/modules/config/networking.nix
@@ -84,6 +84,18 @@ in
       '';
     };
 
+    networking.timeServers = mkOption {
+      default = [
+        "0.nixos.pool.ntp.org"
+        "1.nixos.pool.ntp.org"
+        "2.nixos.pool.ntp.org"
+        "3.nixos.pool.ntp.org"
+      ];
+      description = ''
+        The set of NTP servers from which to synchronise.
+      '';
+    };
+
     networking.proxy = {
 
       default = lib.mkOption {