summary refs log tree commit diff
path: root/nixos/modules/config/ldap.nix
diff options
context:
space:
mode:
authorMarkus Mueller <john.subscriber@markus.institute>2016-07-18 13:20:21 +0000
committerFranz Pletz <fpletz@fnordicwalking.de>2016-08-23 21:12:51 +0200
commite04c3506eb24eb6e08d0938cc469aa140b4ea165 (patch)
tree14c8cafa9f60ba214919fa0579b107de0c606e02 /nixos/modules/config/ldap.nix
parent415e1983ca650777d476d39de1db61a9e9877621 (diff)
downloadnixlib-e04c3506eb24eb6e08d0938cc469aa140b4ea165.tar
nixlib-e04c3506eb24eb6e08d0938cc469aa140b4ea165.tar.gz
nixlib-e04c3506eb24eb6e08d0938cc469aa140b4ea165.tar.bz2
nixlib-e04c3506eb24eb6e08d0938cc469aa140b4ea165.tar.lz
nixlib-e04c3506eb24eb6e08d0938cc469aa140b4ea165.tar.xz
nixlib-e04c3506eb24eb6e08d0938cc469aa140b4ea165.tar.zst
nixlib-e04c3506eb24eb6e08d0938cc469aa140b4ea165.zip
ldap: Add option for login PAM integration
Diffstat (limited to 'nixos/modules/config/ldap.nix')
-rw-r--r--nixos/modules/config/ldap.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/nixos/modules/config/ldap.nix b/nixos/modules/config/ldap.nix
index 7064ef64b4c8..7cbcc39412ea 100644
--- a/nixos/modules/config/ldap.nix
+++ b/nixos/modules/config/ldap.nix
@@ -62,6 +62,12 @@ in
         description = "Whether to enable authentication against an LDAP server.";
       };
 
+      loginPam = mkOption {
+        type = types.bool;
+        default = true;
+        description = "Whether to include authentication against LDAP in login PAM";
+      };
+
       server = mkOption {
         example = "ldap://ldap.example.org/";
         description = "The URL of the LDAP server.";