summary refs log tree commit diff
path: root/nixos/modules/config/i18n.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2014-04-18 19:03:50 +0200
committerEelco Dolstra <eelco.dolstra@logicblox.com>2014-04-18 19:04:45 +0200
commit465d6ff5722cf1c9b7e58793ed50c5bc750c5098 (patch)
treea7ae6495fa6991ac300ae2f66cda19bccad04bbc /nixos/modules/config/i18n.nix
parent313c38d5f1aeda1b065ba9b15380918ebd771c99 (diff)
downloadnixlib-465d6ff5722cf1c9b7e58793ed50c5bc750c5098.tar
nixlib-465d6ff5722cf1c9b7e58793ed50c5bc750c5098.tar.gz
nixlib-465d6ff5722cf1c9b7e58793ed50c5bc750c5098.tar.bz2
nixlib-465d6ff5722cf1c9b7e58793ed50c5bc750c5098.tar.lz
nixlib-465d6ff5722cf1c9b7e58793ed50c5bc750c5098.tar.xz
nixlib-465d6ff5722cf1c9b7e58793ed50c5bc750c5098.tar.zst
nixlib-465d6ff5722cf1c9b7e58793ed50c5bc750c5098.zip
Set $LOCALE_ARCHIVE in all systemd units
This variable used to be inherited implicitly from the stage-2 script,
but systemd now clears the environment. So we need to set it
explicitly.
Diffstat (limited to 'nixos/modules/config/i18n.nix')
-rw-r--r--nixos/modules/config/i18n.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/nixos/modules/config/i18n.nix b/nixos/modules/config/i18n.nix
index dd5e0ae25509..8182b8ae8081 100644
--- a/nixos/modules/config/i18n.nix
+++ b/nixos/modules/config/i18n.nix
@@ -76,7 +76,12 @@ in
 
     environment.systemPackages = [ glibcLocales ];
 
-    environment.variables.LANG = config.i18n.defaultLocale;
+    environment.variables =
+      { LANG = config.i18n.defaultLocale;
+        LOCALE_ARCHIVE = "/run/current-system/sw/lib/locale/locale-archive";
+      };
+
+    systemd.globalEnvironment.LOCALE_ARCHIVE = "${glibcLocales}/lib/locale/locale-archive";
 
     # ‘/etc/locale.conf’ is used by systemd.
     environment.etc = singleton