summary refs log tree commit diff
path: root/nixos/modules/config/i18n.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-30 17:37:45 +0100
committerEelco Dolstra <eelco.dolstra@logicblox.com>2013-10-30 18:47:43 +0100
commit408b8b5725c3e6fff75aef772da248d3e95ff414 (patch)
tree692e3b61dbbff85cc97e3becf13a1376dea04a92 /nixos/modules/config/i18n.nix
parentd882e1966251880240599d3c1b31e060661506ee (diff)
downloadnixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.tar
nixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.tar.gz
nixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.tar.bz2
nixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.tar.lz
nixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.tar.xz
nixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.tar.zst
nixlib-408b8b5725c3e6fff75aef772da248d3e95ff414.zip
Add lots of missing option types
Diffstat (limited to 'nixos/modules/config/i18n.nix')
-rw-r--r--nixos/modules/config/i18n.nix17
1 files changed, 10 insertions, 7 deletions
diff --git a/nixos/modules/config/i18n.nix b/nixos/modules/config/i18n.nix
index 5570bb1adf6b..56d541cb9b3b 100644
--- a/nixos/modules/config/i18n.nix
+++ b/nixos/modules/config/i18n.nix
@@ -18,16 +18,18 @@ in
 
     i18n = {
       defaultLocale = mkOption {
+        type = types.str;
         default = "en_US.UTF-8";
         example = "nl_NL.UTF-8";
-        description = "
+        description = ''
           The default locale.  It determines the language for program
           messages, the format for dates and times, sort order, and so on.
           It also determines the character set, such as UTF-8.
-        ";
+        '';
       };
 
       supportedLocales = mkOption {
+        type = types.listOf types.str;
         default = ["all"];
         example = ["en_US.UTF-8/UTF-8" "nl_NL.UTF-8/UTF-8" "nl_NL/ISO-8859-1"];
         description = ''
@@ -40,22 +42,23 @@ in
       };
 
       consoleFont = mkOption {
+        type = types.str;
         default = "lat9w-16";
         example = "LatArCyrHeb-16";
-        description = "
+        description = ''
           The font used for the virtual consoles.  Leave empty to use
           whatever the <command>setfont</command> program considers the
           default font.
-        ";
+        '';
       };
 
       consoleKeyMap = mkOption {
+        type = types.str;
         default = "us";
         example = "fr";
-        description = "
+        description = ''
           The keyboard mapping table for the virtual consoles.
-        ";
-        type = types.str;
+        '';
       };
 
     };