summary refs log tree commit diff
path: root/nixos/modules/config/i18n.nix
diff options
context:
space:
mode:
authorrnhmjoj <micheleguerinirocco@me.com>2015-09-03 05:27:56 +0200
committerVladimír Čunát <vcunat@gmail.com>2015-11-09 14:53:59 +0100
commit2a0f9d40ff1aecd1713871349d5723547aeab1e4 (patch)
tree3f272cdc2c8675513a207c3c38924cbc52367281 /nixos/modules/config/i18n.nix
parent779d3a2ec702995d1445059b0d46a5f15a39d9a8 (diff)
downloadnixlib-2a0f9d40ff1aecd1713871349d5723547aeab1e4.tar
nixlib-2a0f9d40ff1aecd1713871349d5723547aeab1e4.tar.gz
nixlib-2a0f9d40ff1aecd1713871349d5723547aeab1e4.tar.bz2
nixlib-2a0f9d40ff1aecd1713871349d5723547aeab1e4.tar.lz
nixlib-2a0f9d40ff1aecd1713871349d5723547aeab1e4.tar.xz
nixlib-2a0f9d40ff1aecd1713871349d5723547aeab1e4.tar.zst
nixlib-2a0f9d40ff1aecd1713871349d5723547aeab1e4.zip
i18n: add color scheme option (close #9626)
Diffstat (limited to 'nixos/modules/config/i18n.nix')
-rw-r--r--nixos/modules/config/i18n.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/nixos/modules/config/i18n.nix b/nixos/modules/config/i18n.nix
index f58e540a6e5c..b20fac6ad3e2 100644
--- a/nixos/modules/config/i18n.nix
+++ b/nixos/modules/config/i18n.nix
@@ -74,6 +74,23 @@ in
         '';
       };
 
+      consoleColors = mkOption {
+        type = types.listOf types.str;
+        default = [];
+        example = [
+          "002b36" "dc322f" "859900" "b58900"
+          "268bd2" "d33682" "2aa198" "eee8d5"
+          "002b36" "cb4b16" "586e75" "657b83"
+          "839496" "6c71c4" "93a1a1" "fdf6e3"
+        ];
+        description = ''
+          The 16 colors palette used by the virtual consoles.
+          Leave empty to use the default colors.
+          Colors must be in hexadecimal format and listed in
+          order from color 0 to color 15.
+        '';
+      };
+
     };
 
   };