summary refs log tree commit diff
path: root/nixos/lib/testing.nix
diff options
context:
space:
mode:
authoraszlig <aszlig@redmoonstudios.org>2015-05-22 08:01:17 +0200
committeraszlig <aszlig@redmoonstudios.org>2015-05-22 08:01:17 +0200
commitf12208c5a4833b2b38fdd01cb7cfe23a7cfb79b7 (patch)
tree437a17da401a63962956c44db5ba2b530f3b7f97 /nixos/lib/testing.nix
parentadb7581459f1351272e9a220723aa9f9db29963c (diff)
downloadnixlib-f12208c5a4833b2b38fdd01cb7cfe23a7cfb79b7.tar
nixlib-f12208c5a4833b2b38fdd01cb7cfe23a7cfb79b7.tar.gz
nixlib-f12208c5a4833b2b38fdd01cb7cfe23a7cfb79b7.tar.bz2
nixlib-f12208c5a4833b2b38fdd01cb7cfe23a7cfb79b7.tar.lz
nixlib-f12208c5a4833b2b38fdd01cb7cfe23a7cfb79b7.tar.xz
nixlib-f12208c5a4833b2b38fdd01cb7cfe23a7cfb79b7.tar.zst
nixlib-f12208c5a4833b2b38fdd01cb7cfe23a7cfb79b7.zip
nixos/testing: Use stripped down tesseract only.
Only include the English language for the VM tests, because we most
likely won't need other languages. At least for now.

Signed-off-by: aszlig <aszlig@redmoonstudios.org>
Diffstat (limited to 'nixos/lib/testing.nix')
-rw-r--r--nixos/lib/testing.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/nixos/lib/testing.nix b/nixos/lib/testing.nix
index 2039740a4578..ee254ae187fd 100644
--- a/nixos/lib/testing.nix
+++ b/nixos/lib/testing.nix
@@ -91,6 +91,8 @@ rec {
 
       vms = map (m: m.config.system.build.vm) (lib.attrValues nodes);
 
+      ocrProg = tesseract.override { enableLanguages = [ "eng" ]; };
+
       # Generate onvenience wrappers for running the test driver
       # interactively with the specified network, and for starting the
       # VMs from the command line.
@@ -107,14 +109,14 @@ rec {
           vms="$(for i in ${toString vms}; do echo $i/bin/run-*-vm; done)"
           wrapProgram $out/bin/nixos-test-driver \
             --add-flags "$vms" \
-            ${lib.optionalString enableOCR "--prefix PATH : '${tesseract}/bin'"} \
+            ${lib.optionalString enableOCR "--prefix PATH : '${ocrProg}/bin'"} \
             --run "testScript=\"\$(cat $out/test-script)\"" \
             --set testScript '"$testScript"' \
             --set VLANS '"${toString vlans}"'
           ln -s ${testDriver}/bin/nixos-test-driver $out/bin/nixos-run-vms
           wrapProgram $out/bin/nixos-run-vms \
             --add-flags "$vms" \
-            ${lib.optionalString enableOCR "--prefix PATH : '${tesseract}/bin'"} \
+            ${lib.optionalString enableOCR "--prefix PATH : '${ocrProg}/bin'"} \
             --set tests '"startAll; joinAll;"' \
             --set VLANS '"${toString vlans}"' \
             ${lib.optionalString (builtins.length vms == 1) "--set USE_SERIAL 1"}