summary refs log tree commit diff
path: root/nixos/lib/testing.nix
diff options
context:
space:
mode:
authoraszlig <aszlig@redmoonstudios.org>2017-04-09 23:34:26 +0200
committeraszlig <aszlig@redmoonstudios.org>2017-04-11 03:21:53 +0200
commita443bdc0a637aac3e6c0b8ba9d71f101f60d221d (patch)
tree73bd58de01cabfa6535f49d704d6d2fa86086a1b /nixos/lib/testing.nix
parent7b5263e1a63a69b7dd5f05dd54d9355bc6648fe1 (diff)
downloadnixlib-a443bdc0a637aac3e6c0b8ba9d71f101f60d221d.tar
nixlib-a443bdc0a637aac3e6c0b8ba9d71f101f60d221d.tar.gz
nixlib-a443bdc0a637aac3e6c0b8ba9d71f101f60d221d.tar.bz2
nixlib-a443bdc0a637aac3e6c0b8ba9d71f101f60d221d.tar.lz
nixlib-a443bdc0a637aac3e6c0b8ba9d71f101f60d221d.tar.xz
nixlib-a443bdc0a637aac3e6c0b8ba9d71f101f60d221d.tar.zst
nixlib-a443bdc0a637aac3e6c0b8ba9d71f101f60d221d.zip
nixos/testing: Improve quality of OCR
First of all, we're now using ImageMagick to improve the screenshot so
that Tesseract has an esier time to recognize the text. The resulting
image of this post-processing is a scaled up black-and-white version
with the backgrounds almost entirely removed and the text edges a bit
blurred, so the screen shots now more or less resemble an image from a
scanner rather. This is what Tesseract is trained for by default.

As mentioned in the previous commit we now also use Tesseract 4, which
further improves the quality of text recognition.

I've spent countless hours just to test different postprocessing
variants and testing what works best for our tests and this is the one
that worked best so far. It's certainly not perfect and I'd like to
avoid the scaling step but we're way better off than before.

In addition to this, the OCR process is now done without an intermediate
file, solely using pipes.

I've tested this using the following VM tests which have OCR enabled:

 * nixos/tests/chromium.nix -A stable
 * nixos/tests/emacs-daemon.nix
 * nixos/tests/installer.nix -A luksroot
 * nixos/tests/lightdm.nix
 * nixos/tests/plasma5.nix
 * nixos/tests/sddm.nix

All of the tests still succeed and comparing some of the recognition
results to the earlier results it now also detects a lot more text than
before this commit.

Signed-off-by: aszlig <aszlig@redmoonstudios.org>
Diffstat (limited to 'nixos/lib/testing.nix')
-rw-r--r--nixos/lib/testing.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/nixos/lib/testing.nix b/nixos/lib/testing.nix
index d8b5df004df8..58c447c76db6 100644
--- a/nixos/lib/testing.nix
+++ b/nixos/lib/testing.nix
@@ -93,7 +93,7 @@ rec {
 
       vms = map (m: m.config.system.build.vm) (lib.attrValues nodes);
 
-      ocrProg = tesseract.override { enableLanguages = [ "eng" ]; };
+      ocrProg = tesseract_4.override { enableLanguages = [ "eng" ]; };
 
       # Generate onvenience wrappers for running the test driver
       # interactively with the specified network, and for starting the
@@ -111,7 +111,8 @@ rec {
           vms=($(for i in ${toString vms}; do echo $i/bin/run-*-vm; done))
           wrapProgram $out/bin/nixos-test-driver \
             --add-flags "''${vms[*]}" \
-            ${lib.optionalString enableOCR "--prefix PATH : '${ocrProg}/bin'"} \
+            ${lib.optionalString enableOCR
+              "--prefix PATH : '${ocrProg}/bin:${imagemagick}/bin'"} \
             --run "testScript=\"\$(cat $out/test-script)\"" \
             --set testScript '$testScript' \
             --set VLANS '${toString vlans}'