summary refs log tree commit diff
path: root/nixos/lib/testing.nix
diff options
context:
space:
mode:
authorBjørn Forsman <bjorn.forsman@gmail.com>2014-09-07 15:37:16 +0200
committerBjørn Forsman <bjorn.forsman@gmail.com>2014-09-07 15:47:59 +0200
commit8e8f95beda59ee25d0c7a7acfc3e211b246a1a8f (patch)
treea9099670aa88062a23e7514550aaf6391bf8782f /nixos/lib/testing.nix
parentaf26d5e25b12316f350723a0d9eac3af8ce0baca (diff)
downloadnixlib-8e8f95beda59ee25d0c7a7acfc3e211b246a1a8f.tar
nixlib-8e8f95beda59ee25d0c7a7acfc3e211b246a1a8f.tar.gz
nixlib-8e8f95beda59ee25d0c7a7acfc3e211b246a1a8f.tar.bz2
nixlib-8e8f95beda59ee25d0c7a7acfc3e211b246a1a8f.tar.lz
nixlib-8e8f95beda59ee25d0c7a7acfc3e211b246a1a8f.tar.xz
nixlib-8e8f95beda59ee25d0c7a7acfc3e211b246a1a8f.tar.zst
nixlib-8e8f95beda59ee25d0c7a7acfc3e211b246a1a8f.zip
nixos/test-reports: use local copy of jquery
The current way test reports get jquery,

  src="//ajax.googleapis.com/ajax/libs/jquery/1.8.3/jquery.min.js"

only works when getting reports over http:// or https://, not file://.
Change it so that it works for all protocols by using a local copy of
jquery.

This fixes the issue where locally created and browsed test reports
cannot be navigated properly; clicking the '+' symbol to expand
sub-sections doesn't work.
Diffstat (limited to 'nixos/lib/testing.nix')
-rw-r--r--nixos/lib/testing.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/nixos/lib/testing.nix b/nixos/lib/testing.nix
index 0e23fc5d187d..75e9c3977763 100644
--- a/nixos/lib/testing.nix
+++ b/nixos/lib/testing.nix
@@ -53,6 +53,8 @@ rec {
           xsltproc --output $out/log.html ${./test-driver/log2html.xsl} $out/log.xml
           ln -s ${./test-driver/logfile.css} $out/logfile.css
           ln -s ${./test-driver/treebits.js} $out/treebits.js
+          ln -s ${jquery}/js/jquery.min.js $out/
+          ln -s ${jquery-ui}/js/jquery-ui.min.js $out/
 
           touch $out/nix-support/hydra-build-products
           echo "report testlog $out log.html" >> $out/nix-support/hydra-build-products