summary refs log tree commit diff
path: root/nixos/doc/manual/shell.nix
diff options
context:
space:
mode:
authorSamuel Dionne-Riel <samuel@dionne-riel.com>2018-05-31 20:26:27 -0400
committerSamuel Dionne-Riel <samuel@dionne-riel.com>2018-05-31 21:02:15 -0400
commitbc0421c4cf18c431ece8d6a19f723159316f55ff (patch)
tree6c81b79df1a0ad4c24519a508f15e81fea2d5126 /nixos/doc/manual/shell.nix
parentaa59151c21c353923b3f003662f17f2210c63c57 (diff)
downloadnixlib-bc0421c4cf18c431ece8d6a19f723159316f55ff.tar
nixlib-bc0421c4cf18c431ece8d6a19f723159316f55ff.tar.gz
nixlib-bc0421c4cf18c431ece8d6a19f723159316f55ff.tar.bz2
nixlib-bc0421c4cf18c431ece8d6a19f723159316f55ff.tar.lz
nixlib-bc0421c4cf18c431ece8d6a19f723159316f55ff.tar.xz
nixlib-bc0421c4cf18c431ece8d6a19f723159316f55ff.tar.zst
nixlib-bc0421c4cf18c431ece8d6a19f723159316f55ff.zip
doc: Adds xml fixing script. (see previous and next commits)
This script is used to automatically fix issues within xml documentation
files.

The script is *for now* intended to be used ad-hoc, and the commits to
be examined.

A future discussion will define whether:

  * This commit and scripts are kept.
  * The script is extended for common use.

The biggest issue right now with the script is that it *could* in theory
destroy a valid space-less varlistentry.

The script could, in practical use, be changed and extended to normalize
some parts of the XML files, mainly:

  * A common quoting style for attributes
  * Fix-up some weird formatting automatically that xmlformat doesn't
    catch
Diffstat (limited to 'nixos/doc/manual/shell.nix')
-rw-r--r--nixos/doc/manual/shell.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/nixos/doc/manual/shell.nix b/nixos/doc/manual/shell.nix
index 7f8422b4ec11..cc3609d750e0 100644
--- a/nixos/doc/manual/shell.nix
+++ b/nixos/doc/manual/shell.nix
@@ -4,5 +4,5 @@ in
 pkgs.mkShell {
   name = "nixos-manual";
 
-  buildInputs = with pkgs; [ xmlformat jing xmloscopy ];
+  buildInputs = with pkgs; [ xmlformat jing xmloscopy ruby ];
 }