summary refs log tree commit diff
path: root/modules/services/x11/xserver.nix
diff options
context:
space:
mode:
authoraszlig <aszlig@redmoonstudios.org>2013-01-09 22:19:58 +0100
committeraszlig <aszlig@redmoonstudios.org>2013-01-09 22:28:09 +0100
commite4d949ec8801af8662c206d08d95ff41ba640d08 (patch)
treeddd3f546a4d4602535b298f82a92f880f0fd8abf /modules/services/x11/xserver.nix
parent0412d6413e897b6088df3a620cf60dcb8e647129 (diff)
downloadnixlib-e4d949ec8801af8662c206d08d95ff41ba640d08.tar
nixlib-e4d949ec8801af8662c206d08d95ff41ba640d08.tar.gz
nixlib-e4d949ec8801af8662c206d08d95ff41ba640d08.tar.bz2
nixlib-e4d949ec8801af8662c206d08d95ff41ba640d08.tar.lz
nixlib-e4d949ec8801af8662c206d08d95ff41ba640d08.tar.xz
nixlib-e4d949ec8801af8662c206d08d95ff41ba640d08.tar.zst
nixlib-e4d949ec8801af8662c206d08d95ff41ba640d08.zip
xserver: Allow to add extra options to xorg config.
This is especially useful if you want to supply a default XRandR configuration,
where you need multiple "Monitor" sections in order to set properties for
specific CRTCs (if not running in zaphod mode).

Signed-off-by: aszlig <aszlig@redmoonstudios.org>
Diffstat (limited to 'modules/services/x11/xserver.nix')
-rw-r--r--modules/services/x11/xserver.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/modules/services/x11/xserver.nix b/modules/services/x11/xserver.nix
index 421f80c42bbb..bfdeef81f206 100644
--- a/modules/services/x11/xserver.nix
+++ b/modules/services/x11/xserver.nix
@@ -281,6 +281,25 @@ in
         description = "Lines to be added to every Display subsection of the Screen section.";
       };
 
+      extraXorgOptions = mkOption {
+        default = "";
+        example = ''
+          Section "Monitor"
+            Identifier "left monitor"
+          EndSection
+
+          Section "Monitor"
+            Identifier "right monitor"
+            Option "RightOf" "left monitor"
+          EndSection
+        '';
+        type = types.string;
+        description = ''
+          Additional options you want to append to your X server configuration
+          file.
+        '';
+      };
+
       defaultDepth = mkOption {
         default = 0;
         example = 8;
@@ -552,6 +571,8 @@ in
 
           EndSection
         '')}
+
+        ${cfg.extraXorgOptions}
       '';
 
   });