summary refs log tree commit diff
path: root/modules/services/x11/xserver.nix
diff options
context:
space:
mode:
authorJan Malakhovski <oxij@oxij.org>2013-09-18 03:18:34 +0000
committerJan Malakhovski <oxij@oxij.org>2013-09-23 16:55:25 +0000
commitb3f4040512b360397bb8989a85776335ff3c2847 (patch)
tree073caf06d9da668210278762dd74954063356fb4 /modules/services/x11/xserver.nix
parent58e40f84e19b9663c40e5de0b387d267d7d2d0d6 (diff)
downloadnixlib-b3f4040512b360397bb8989a85776335ff3c2847.tar
nixlib-b3f4040512b360397bb8989a85776335ff3c2847.tar.gz
nixlib-b3f4040512b360397bb8989a85776335ff3c2847.tar.bz2
nixlib-b3f4040512b360397bb8989a85776335ff3c2847.tar.lz
nixlib-b3f4040512b360397bb8989a85776335ff3c2847.tar.xz
nixlib-b3f4040512b360397bb8989a85776335ff3c2847.tar.zst
nixlib-b3f4040512b360397bb8989a85776335ff3c2847.zip
Radically change the way NixOS handles environment variables and make it possible not to use Bash as the default interactive shell.
This change does two things:

* "NixOSizes" environment variables generation. This allows some more
  error-checking and opens possibilities for a modular environment
  configuration. From now on the most of environment variables are
  generated directly by the nix code. Generating sh code that
  generates environment variables is left in a few places where
  nontrivial access to a local environment state is needed.
* By doing the first change this patch untangles bash from the
  environment configuration and makes it trivial to add a support for
  other non bash-compatible shells.

Now to the sad part. This change is quite large (and I'm not sure it's
possible to split it) and yet is not quite complete, it needs some
changes to nixpkgs to be perfect.
See !!! comments in modules/config/shells-environment.nix.

Main principle behind this change is "change environment generation
and nothing else". In particular, shell configuration principles stay
exactly the same as before.
Diffstat (limited to 'modules/services/x11/xserver.nix')
-rw-r--r--modules/services/x11/xserver.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/modules/services/x11/xserver.nix b/modules/services/x11/xserver.nix
index 40da6a743891..2c76361ea4bf 100644
--- a/modules/services/x11/xserver.nix
+++ b/modules/services/x11/xserver.nix
@@ -409,6 +409,9 @@ in
     boot.blacklistedKernelModules =
       optionals (elem "nvidia" driverNames) [ "nouveau" "nvidiafb" ];
 
+    environment.variables.LD_LIBRARY_PATH.list =
+      [ "/run/opengl-driver/lib" "/run/opengl-driver-32/lib" ];
+
     environment.etc =
       (optionals cfg.exportConfiguration
         [ { source = "${configFile}";