summary refs log tree commit diff
path: root/modules/services/x11/xserver.nix
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2009-11-22 00:40:48 +0000
committerLudovic Courtès <ludo@gnu.org>2009-11-22 00:40:48 +0000
commit8c349a9e71961c9b599c0cfa46aa11c085085e63 (patch)
tree9fd9af896ae8aca53e6879ffc4221b8ffb8d9345 /modules/services/x11/xserver.nix
parent66d8af6d091af58aa2cc7bdc4e85c3545f8d3ae2 (diff)
downloadnixlib-8c349a9e71961c9b599c0cfa46aa11c085085e63.tar
nixlib-8c349a9e71961c9b599c0cfa46aa11c085085e63.tar.gz
nixlib-8c349a9e71961c9b599c0cfa46aa11c085085e63.tar.bz2
nixlib-8c349a9e71961c9b599c0cfa46aa11c085085e63.tar.lz
nixlib-8c349a9e71961c9b599c0cfa46aa11c085085e63.tar.xz
nixlib-8c349a9e71961c9b599c0cfa46aa11c085085e63.tar.zst
nixlib-8c349a9e71961c9b599c0cfa46aa11c085085e63.zip
Fix the OpenSSH/GnuPG agent assertion.
svn path=/nixos/trunk/; revision=18514
Diffstat (limited to 'modules/services/x11/xserver.nix')
-rw-r--r--modules/services/x11/xserver.nix11
1 files changed, 7 insertions, 4 deletions
diff --git a/modules/services/x11/xserver.nix b/modules/services/x11/xserver.nix
index ee6f7c50f122..62fb26f829e9 100644
--- a/modules/services/x11/xserver.nix
+++ b/modules/services/x11/xserver.nix
@@ -340,11 +340,14 @@ in
           message = "The X server needs HAL running. Set services.hal.enable to true";
         }
 
-        { assertion = (cfg.startSSHAgent -> !cfg.startGnuPGAgent)
-                       && (cfg.startGnuPGAgent -> !cfg.startSSHAgent);
+        { assertion = if cfg.startSSHAgent
+                      then !cfg.startGnuPGAgent
+                      else (if cfg.startGnuPGAgent
+                            then !cfg.startSSHAgent
+                            else true);
           message =
-            "The OpenSSH SSH agent and GnuPG agent cannot be started " +
-            "both.  Choose between `startSSHAgent' and `startGnuPGAgent'.";
+            "The OpenSSH agent and GnuPG agent cannot be started both.  "
+            "Choose between `startSSHAgent' and `startGnuPGAgent'.";
         }
       ];