summary refs log tree commit diff
path: root/modules/services/x11/xserver.nix
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2010-08-09 20:10:16 +0000
committerEelco Dolstra <eelco.dolstra@logicblox.com>2010-08-09 20:10:16 +0000
commit31db968be471f8fcec844f2127530bd0435ed57b (patch)
treea0c23558407f2990d7b7428910d8b43c165b5448 /modules/services/x11/xserver.nix
parent057602f3f2e64cf9b01339a4dab5988fbcdf4288 (diff)
downloadnixlib-31db968be471f8fcec844f2127530bd0435ed57b.tar
nixlib-31db968be471f8fcec844f2127530bd0435ed57b.tar.gz
nixlib-31db968be471f8fcec844f2127530bd0435ed57b.tar.bz2
nixlib-31db968be471f8fcec844f2127530bd0435ed57b.tar.lz
nixlib-31db968be471f8fcec844f2127530bd0435ed57b.tar.xz
nixlib-31db968be471f8fcec844f2127530bd0435ed57b.tar.zst
nixlib-31db968be471f8fcec844f2127530bd0435ed57b.zip
* In QEMU, set a higher refresh rate in xorg.conf so that resolutions
  higher than 800x600 work.
* Add a "Monitor" statement to the "Screen" section, because otherwise
  the Monitor section is ignored.

svn path=/nixos/trunk/; revision=23068
Diffstat (limited to 'modules/services/x11/xserver.nix')
-rw-r--r--modules/services/x11/xserver.nix12
1 files changed, 9 insertions, 3 deletions
diff --git a/modules/services/x11/xserver.nix b/modules/services/x11/xserver.nix
index ddb6047df215..38822b2627ab 100644
--- a/modules/services/x11/xserver.nix
+++ b/modules/services/x11/xserver.nix
@@ -137,6 +137,7 @@ in
 
       resolutions = mkOption {
         default = [];
+        example = [ { x = 1600; y = 1200; } { x = 1024; y = 786; } ];
         description = ''
           The screen resolutions for the X server.  The first element
           is the default resolution.  If this list is empty, the X
@@ -496,6 +497,9 @@ in
           Section "Screen"
             Identifier "Screen-${driver.name}[0]"
             Device "Device-${driver.name}[0]"
+            ${optionalString (cfg.monitorSection != "") ''
+              Monitor "Monitor[0]"
+            ''}
 
             ${cfg.screenSection}
 
@@ -508,9 +512,11 @@ in
             ''}
 
             ${optionalString
-                (driver.name != "virtualbox" && (cfg.resolutions != []
-                 || cfg.extraDisplaySettings != "" || cfg.virtualScreen != null)) (
-              let
+                (driver.name != "virtualbox" &&
+                 (cfg.resolutions != [] ||
+                  cfg.extraDisplaySettings != "" ||
+                  cfg.virtualScreen != null))
+              (let
                 f = depth:
                   ''
                     SubSection "Display"