summary refs log tree commit diff
path: root/lib/types.nix
diff options
context:
space:
mode:
authorSilvan Mosberger <infinisil@icloud.com>2018-04-04 16:55:45 +0200
committerProfpatsch <mail@profpatsch.de>2018-05-06 23:58:36 +0200
commitcd5736116c971ed08826b71a15a2221233b3d44f (patch)
tree936800e16966c98d6cbdbf555669ac89c5db7574 /lib/types.nix
parentb16a69289aae7a8aeb7d0410649764d9d2328e2f (diff)
downloadnixlib-cd5736116c971ed08826b71a15a2221233b3d44f.tar
nixlib-cd5736116c971ed08826b71a15a2221233b3d44f.tar.gz
nixlib-cd5736116c971ed08826b71a15a2221233b3d44f.tar.bz2
nixlib-cd5736116c971ed08826b71a15a2221233b3d44f.tar.lz
nixlib-cd5736116c971ed08826b71a15a2221233b3d44f.tar.xz
nixlib-cd5736116c971ed08826b71a15a2221233b3d44f.tar.zst
nixlib-cd5736116c971ed08826b71a15a2221233b3d44f.zip
lib/types: clear up coercedTo description
Diffstat (limited to 'lib/types.nix')
-rw-r--r--lib/types.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/lib/types.nix b/lib/types.nix
index 45b0ae5042ce..4ee9affcb297 100644
--- a/lib/types.nix
+++ b/lib/types.nix
@@ -256,7 +256,7 @@ rec {
       functor = (defaultFunctor name) // { wrapped = elemType; };
     };
 
-    nonEmptyListOf = elemType: 
+    nonEmptyListOf = elemType:
       let list = addCheck (types.listOf elemType) (l: l != []);
       in list // { description = "non-empty " + list.description; };
 
@@ -419,7 +419,7 @@ rec {
       assert coercedType.getSubModules == null;
       mkOptionType rec {
         name = "coercedTo";
-        description = "${finalType.description} or ${coercedType.description}";
+        description = "${finalType.description} or ${coercedType.description} convertible to it";
         check = x: finalType.check x || (coercedType.check x && finalType.check (coerceFunc x));
         merge = loc: defs:
           let