summary refs log tree commit diff
path: root/lib/types.nix
diff options
context:
space:
mode:
authorProfpatsch <mail@profpatsch.de>2017-11-03 12:20:35 +0100
committerProfpatsch <mail@profpatsch.de>2017-11-05 15:56:32 +0100
commit213bd2847bb6590126591435766793df0410b4d1 (patch)
treeb462824de44607c92210f4c5167da2253e5dbb9c /lib/types.nix
parent462c048c77fa0aa0cb4c47d7812a57f094587f68 (diff)
downloadnixlib-213bd2847bb6590126591435766793df0410b4d1.tar
nixlib-213bd2847bb6590126591435766793df0410b4d1.tar.gz
nixlib-213bd2847bb6590126591435766793df0410b4d1.tar.bz2
nixlib-213bd2847bb6590126591435766793df0410b4d1.tar.lz
nixlib-213bd2847bb6590126591435766793df0410b4d1.tar.xz
nixlib-213bd2847bb6590126591435766793df0410b4d1.tar.zst
nixlib-213bd2847bb6590126591435766793df0410b4d1.zip
lib/types: fix up documentation formatting a bit
Diffstat (limited to 'lib/types.nix')
-rw-r--r--lib/types.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/lib/types.nix b/lib/types.nix
index 1675a54156df..adbae8f08a54 100644
--- a/lib/types.nix
+++ b/lib/types.nix
@@ -114,7 +114,7 @@ rec {
         merge = mergeOneOption;
       };
 
-    # specialized subdomains of int
+    # Specialized subdomains of int
     ints =
       let
         betweenDesc = lowest: highest:
@@ -225,7 +225,7 @@ rec {
     };
 
     # drop this in the future:
-    list = builtins.trace "`types.list' is deprecated; use `types.listOf' instead" types.listOf;
+    list = builtins.trace "`types.list` is deprecated; use `types.listOf` instead" types.listOf;
 
     listOf = elemType: mkOptionType rec {
       name = "listOf";
@@ -242,7 +242,7 @@ rec {
               ).optionalValue
             ) def.value
           else
-            throw "The option value `${showOption loc}' in `${def.file}' is not a list.") defs)));
+            throw "The option value `${showOption loc}` in `${def.file}` is not a list.") defs)));
       getSubOptions = prefix: elemType.getSubOptions (prefix ++ ["*"]);
       getSubModules = elemType.getSubModules;
       substSubModules = m: listOf (elemType.substSubModules m);
@@ -313,7 +313,7 @@ rec {
         let nrNulls = count (def: def.value == null) defs; in
         if nrNulls == length defs then null
         else if nrNulls != 0 then
-          throw "The option `${showOption loc}' is defined both null and not null, in ${showFiles (getFiles defs)}."
+          throw "The option `${showOption loc}` is defined both null and not null, in ${showFiles (getFiles defs)}."
         else elemType.merge loc defs;
       getSubOptions = elemType.getSubOptions;
       getSubModules = elemType.getSubModules;