summary refs log tree commit diff
path: root/lib/types.nix
diff options
context:
space:
mode:
authorSamuel Dionne-Riel <samuel@dionne-riel.com>2018-05-16 12:11:36 -0400
committerxeji <36407913+xeji@users.noreply.github.com>2018-05-16 18:11:36 +0200
commit136f1c470665a9328bb4120f3a4d9af774dadb2d (patch)
treecaf15691266773c71fc009d2f045a76ec8816ec6 /lib/types.nix
parent4fbd5a6583343b42c7b301cc8b065e8f3d212fee (diff)
downloadnixlib-136f1c470665a9328bb4120f3a4d9af774dadb2d.tar
nixlib-136f1c470665a9328bb4120f3a4d9af774dadb2d.tar.gz
nixlib-136f1c470665a9328bb4120f3a4d9af774dadb2d.tar.bz2
nixlib-136f1c470665a9328bb4120f3a4d9af774dadb2d.tar.lz
nixlib-136f1c470665a9328bb4120f3a4d9af774dadb2d.tar.xz
nixlib-136f1c470665a9328bb4120f3a4d9af774dadb2d.tar.zst
nixlib-136f1c470665a9328bb4120f3a4d9af774dadb2d.zip
doc: Fixes documented default option for `<name>` for submodules. (#40464)
Fixes #40463

This is related to change 1d56d0c8a79334cd7149fd580512046558eaac78
Diffstat (limited to 'lib/types.nix')
-rw-r--r--lib/types.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/lib/types.nix b/lib/types.nix
index 772716897725..5aa09d33e9b3 100644
--- a/lib/types.nix
+++ b/lib/types.nix
@@ -372,7 +372,13 @@ rec {
             # This is mandatory as some option declaration might use the
             # "name" attribute given as argument of the submodule and use it
             # as the default of option declarations.
-            args.name = "&lt;name&gt;";
+            #
+            # Using lookalike unicode single angle quotation marks because
+            # of the docbook transformation the options receive. In all uses
+            # &gt; and &lt; wouldn't be encoded correctly so the encoded values
+            # would be used, and use of `<` and `>` would break the XML document.
+            # It shouldn't cause an issue since this is cosmetic for the manual.
+            args.name = "‹name›";
           }).options;
         getSubModules = opts';
         substSubModules = m: submodule m;