summary refs log tree commit diff
path: root/lib/trivial.nix
diff options
context:
space:
mode:
authorProfpatsch <mail@profpatsch.de>2018-08-08 19:26:52 +0200
committerProfpatsch <mail@profpatsch.de>2018-09-06 18:14:27 +0200
commitefdf618330a22f837f0e5e446028e918a5b4dd8a (patch)
tree6b9ad4353a2e470a3bccbbdca89247047263062b /lib/trivial.nix
parent3e45b61a9920466a8ea06b8ad9350d56ade435bc (diff)
downloadnixlib-efdf618330a22f837f0e5e446028e918a5b4dd8a.tar
nixlib-efdf618330a22f837f0e5e446028e918a5b4dd8a.tar.gz
nixlib-efdf618330a22f837f0e5e446028e918a5b4dd8a.tar.bz2
nixlib-efdf618330a22f837f0e5e446028e918a5b4dd8a.tar.lz
nixlib-efdf618330a22f837f0e5e446028e918a5b4dd8a.tar.xz
nixlib-efdf618330a22f837f0e5e446028e918a5b4dd8a.tar.zst
nixlib-efdf618330a22f837f0e5e446028e918a5b4dd8a.zip
lib: move assertMsg and assertOneOf to their own library file
Since the `assertOneOf` uses `lib.generators`, they are not really trivial
anymore and should go into their own library file.
Diffstat (limited to 'lib/trivial.nix')
-rw-r--r--lib/trivial.nix40
1 files changed, 1 insertions, 39 deletions
diff --git a/lib/trivial.nix b/lib/trivial.nix
index f1001ee10ca3..b1eea0bf1247 100644
--- a/lib/trivial.nix
+++ b/lib/trivial.nix
@@ -171,7 +171,7 @@ rec {
     builtins.fromJSON (builtins.readFile path);
 
 
-  ## Warnings and asserts
+  ## Warnings
 
   /* See https://github.com/NixOS/nix/issues/749. Eventually we'd like these
      to expand to Nix builtins that carry metadata so that Nix can filter out
@@ -188,44 +188,6 @@ rec {
   warn = msg: builtins.trace "WARNING: ${msg}";
   info = msg: builtins.trace "INFO: ${msg}";
 
-  /* Print a trace message if pred is false.
-     Intended to be used to augment asserts with helpful error messages.
-
-     Example:
-       assertMsg false "nope"
-       => false
-       stderr> trace: nope
-
-       assert (assertMsg ("foo" == "bar") "foo is not bar, silly"); ""
-       stderr> trace: foo is not bar, silly
-       stderr> assert failed at …
-
-     Type:
-       assertMsg :: Bool -> String -> Bool
-  */
-  # TODO(Profpatsch): add tests that check stderr
-  assertMsg = pred: msg:
-    if pred
-    then true
-    else builtins.trace msg false;
-
-  /* Specialized `assertMsg` for checking if val is one of the elements
-     of a list. Useful for checking enums.
-
-     Example:
-       let sslLibrary = "libressl"
-       in assertOneOf "sslLibrary" sslLibrary [ "openssl" "bearssl" ]
-       => false
-       stderr> trace: sslLibrary must be one of "openssl", "bearssl", but is: "libressl"
-
-     Type:
-       assertOneOf :: String -> ComparableVal -> List ComparableVal -> Bool
-  */
-  assertOneOf = name: val: xs: assertMsg
-    (lib.elem val xs)
-    "${name} must be one of ${
-      lib.generators.toPretty {} xs}, but is: ${
-        lib.generators.toPretty {} val}";
 
   ## Function annotations