summary refs log tree commit diff
path: root/lib/tests/release.nix
diff options
context:
space:
mode:
authorJohn Ericson <Ericson2314@yahoo.com>2017-04-17 17:28:01 -0400
committerGitHub <noreply@github.com>2017-04-17 17:28:01 -0400
commitf0b634c7e838cdd65ac6f73933c99af3f38d0fa8 (patch)
treed2c2909fc40eb2e631a6f88ee3bec58c9493035e /lib/tests/release.nix
parent37e5e71fdf098a45471537e9961672592ef6f72a (diff)
parent3efc661a1de6a2ce9b98aa39283e68914297b8d7 (diff)
downloadnixlib-f0b634c7e838cdd65ac6f73933c99af3f38d0fa8.tar
nixlib-f0b634c7e838cdd65ac6f73933c99af3f38d0fa8.tar.gz
nixlib-f0b634c7e838cdd65ac6f73933c99af3f38d0fa8.tar.bz2
nixlib-f0b634c7e838cdd65ac6f73933c99af3f38d0fa8.tar.lz
nixlib-f0b634c7e838cdd65ac6f73933c99af3f38d0fa8.tar.xz
nixlib-f0b634c7e838cdd65ac6f73933c99af3f38d0fa8.tar.zst
nixlib-f0b634c7e838cdd65ac6f73933c99af3f38d0fa8.zip
Merge pull request #24610 from Ericson2314/platform-normalization
Platform normalization
Diffstat (limited to 'lib/tests/release.nix')
-rw-r--r--lib/tests/release.nix57
1 files changed, 33 insertions, 24 deletions
diff --git a/lib/tests/release.nix b/lib/tests/release.nix
index f9f57424f7d0..dfa4ca2676d1 100644
--- a/lib/tests/release.nix
+++ b/lib/tests/release.nix
@@ -1,31 +1,40 @@
-{ nixpkgs }:
+{ nixpkgs ? { outPath = (import ../.).cleanSource ../..; revCount = 1234; shortRev = "abcdef"; }
+, # The platforms for which we build Nixpkgs.
+  supportedSystems ? [ builtins.currentSystem ]
+, # Strip most of attributes when evaluating to spare memory usage
+  scrubJobs ? true
+}:
 
-with import ../.. { };
+with import ../../pkgs/top-level/release-lib.nix { inherit supportedSystems scrubJobs; };
 with lib;
 
-stdenv.mkDerivation {
-  name = "nixpkgs-lib-tests";
-  buildInputs = [ nix ];
-  NIX_PATH="nixpkgs=${nixpkgs}";
+{
+  systems = import ./systems.nix { inherit lib assertTrue; };
 
-  buildCommand = ''
-    datadir="${nix}/share"
-    export TEST_ROOT=$(pwd)/test-tmp
-    export NIX_BUILD_HOOK=
-    export NIX_CONF_DIR=$TEST_ROOT/etc
-    export NIX_DB_DIR=$TEST_ROOT/db
-    export NIX_LOCALSTATE_DIR=$TEST_ROOT/var
-    export NIX_LOG_DIR=$TEST_ROOT/var/log/nix
-    export NIX_MANIFESTS_DIR=$TEST_ROOT/var/nix/manifests
-    export NIX_STATE_DIR=$TEST_ROOT/var/nix
-    export NIX_STORE_DIR=$TEST_ROOT/store
-    export PAGER=cat
-    cacheDir=$TEST_ROOT/binary-cache
-    nix-store --init
+  moduleSystem = pkgs.stdenv.mkDerivation {
+    name = "nixpkgs-lib-tests";
+    buildInputs = [ pkgs.nix ];
+    NIX_PATH="nixpkgs=${nixpkgs}";
 
-    cd ${nixpkgs}/lib/tests
-    ./modules.sh
+    buildCommand = ''
+      datadir="${pkgs.nix}/share"
+      export TEST_ROOT=$(pwd)/test-tmp
+      export NIX_BUILD_HOOK=
+      export NIX_CONF_DIR=$TEST_ROOT/etc
+      export NIX_DB_DIR=$TEST_ROOT/db
+      export NIX_LOCALSTATE_DIR=$TEST_ROOT/var
+      export NIX_LOG_DIR=$TEST_ROOT/var/log/nix
+      export NIX_MANIFESTS_DIR=$TEST_ROOT/var/nix/manifests
+      export NIX_STATE_DIR=$TEST_ROOT/var/nix
+      export NIX_STORE_DIR=$TEST_ROOT/store
+      export PAGER=cat
+      cacheDir=$TEST_ROOT/binary-cache
+      nix-store --init
 
-    touch $out
-  '';
+      cd ${nixpkgs}/lib/tests
+      ./modules.sh
+
+      touch $out
+    '';
+  };
 }