summary refs log tree commit diff
path: root/lib/systems/platforms.nix
diff options
context:
space:
mode:
authorCrystalGamma <github@crystalgamma.de>2018-08-21 21:31:34 +0200
committerJohn Ericson <mail@JohnEricson.me>2018-08-21 15:31:34 -0400
commit72d161f548701a2a8dab334dee76b63bccc0f07c (patch)
treeb7e2e8d922684bd5b7c3d269454a0a8145a44e46 /lib/systems/platforms.nix
parentcb44c3ff4cf2c15c7e870df482126bd09ce46588 (diff)
downloadnixlib-72d161f548701a2a8dab334dee76b63bccc0f07c.tar
nixlib-72d161f548701a2a8dab334dee76b63bccc0f07c.tar.gz
nixlib-72d161f548701a2a8dab334dee76b63bccc0f07c.tar.bz2
nixlib-72d161f548701a2a8dab334dee76b63bccc0f07c.tar.lz
nixlib-72d161f548701a2a8dab334dee76b63bccc0f07c.tar.xz
nixlib-72d161f548701a2a8dab334dee76b63bccc0f07c.tar.zst
nixlib-72d161f548701a2a8dab334dee76b63bccc0f07c.zip
[RFC] ppc64le enablement (#45340)
* ppc64le enablement

* gcc, glibc: properly handle __float128

* lib/systems, stdenv: syntax cleanup

* gcc7: remove ugly hack

* gcc: add/update __float128 flags

* stdenv: add another pair of quotes for consistency

* gcc: move __float128 flag for ppc64le-glibc into common/platform-flags.nix
Diffstat (limited to 'lib/systems/platforms.nix')
-rw-r--r--lib/systems/platforms.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/lib/systems/platforms.nix b/lib/systems/platforms.nix
index 8027f6b9fc1b..56783d99e3d4 100644
--- a/lib/systems/platforms.nix
+++ b/lib/systems/platforms.nix
@@ -20,6 +20,22 @@ rec {
     kernelAutoModules = false;
   };
 
+  powernv = {
+    name = "PowerNV";
+    kernelArch = "powerpc";
+    kernelBaseConfig = "powernv_defconfig";
+    kernelTarget = "zImage";
+    kernelInstallTarget = "install";
+    kernelFile = "vmlinux";
+    kernelAutoModules = true;
+    # avoid driver/FS trouble arising from unusual page size
+    kernelExtraConfig = ''
+      PPC_64K_PAGES n
+      PPC_4K_PAGES y
+      IPV6 y
+    '';
+  };
+
   ##
   ## ARM
   ##
@@ -458,5 +474,6 @@ rec {
       "armv7l-linux" = armv7l-hf-multiplatform;
       "aarch64-linux" = aarch64-multiplatform;
       "mipsel-linux" = fuloong2f_n32;
+      "powerpc64le-linux" = powernv;
     }.${system} or pcBase;
 }